Incremental backup issues after 2.3.8->2.4.11 upgrade

After upgrade everything seemed OK, but sites, with sql dump enabled, (both mysql/mariadb and postgresql) started to report failed incremental backup. Server Debian stretch, Urbackup 2.4.11
Clients 2.4.9. Btrfs file system. Internet only backup.
On the same client, with same settings, full backup works just fine, and when the sqldump was disabled, the incremental backup worked!

|Info|2019.11.10 10:56|postgresqldump.sql: Starting dump backup of PostgreSQL at Sun Nov 10 10:50:09 CET 2019…|
|Info|2019.11.10 10:56|postgresqldump.sql: Backup of PostgreSQL finished at Sun Nov 10 10:56:00 CET 2019.|
|Info|2019.11.10 10:56|Waiting for file hashing and copying threads…|
|Errors|2019.11.10 10:59|Writing metadata to /var/backups/urbackup/pdb/191110-0949/.hashes/urbackup_backup_scripts/postgresqldump.sql failed|
|Info|2019.11.10 11:00|Writing new file list…|
|Info|2019.11.10 11:00|All metadata was present|
|Errors|2019.11.10 11:00|Fatal error during backup. Backup not completed|
|Info|2019.11.10 11:02|Transferred 12.1239 GB - Average speed: 263.483 MBit/s|
|Errors|2019.11.10 11:02|FATAL: Backup failed because of disk problems (see previous messages)|
|Info|2019.11.10 11:04|Time taken for backing up client pdb.ih: 15m 9s|
|Errors|2019.11.10 11:04|Backup failed|


Waiting for file hashing and copying threads…
2019-11-10 17:31:12: WARNING: File “/var/backups/urbackup/host/191110-1721/.hashes/urbackup_backup_scripts/mariadbdump.sql” has wrong size. Should=8 is=239
. Error writing metadata to file. -1
2019-11-10 17:31:12: ERROR: Writing metadata to /var/backups/urbackup/host/191110-1721/.hashes/urbackup_backup_scripts/mariadbdump.sql failed

Thanks for the report. Was only able to reproduce this when “Incremental file backup transfer mode” was set to Hashed. So a work-around would be to set it to Block differences - hashed.

Should be fixed with the next server update.

Thanks for checking!
I can confirm, setting both Local incremental file backup transfer mode:
and Internet incremental file backup transfer mode: to Block differences - hashed solved the problem. But when I tried with hashed, or raw, the backup failed!
My temporary and ugly workaround was to put dbdump creation to pre backup script.