Inaccessible backup destination: Backup Status [Solved]

EDIT: Solution was to create
mkdir /home/urbackup
chown urbackup:urbackup /home/urbackup

The attempt to create /home/benek/urbackup did notwork in spite of chmod, chown, setfacl (that one should have solved the problem I think but it failed for some reason).
For example I don’t know why this did not work:
setfacl -m u:urbackup:rwx /home/benek/urbackup
setfacl -m g:urbackup:rwx /home/benek/urbackup

Anyhow, the problem went away. Will continue to explore the fantastic software.

This is a fresh fedora 23 installation.

Filesystem Size Used Avail Use% Mounted on
devtmpfs 3.9G 0 3.9G 0% /dev
tmpfs 3.9G 8.0K 3.9G 1% /dev/shm
tmpfs 3.9G 784K 3.9G 1% /run
tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
/dev/mapper/fedora–server-root 50G 25G 23G 53% /
tmpfs 3.9G 4.0K 3.9G 1% /tmp
/dev/sda2 477M 115M 333M 26% /boot
/dev/sda1 200M 8.3M 192M 5% /boot/efi
/dev/mapper/fedora–server-home 860G 26G 790G 4% /home
tmpfs 789M 0 789M 0% /run/user/1000

I need to store backups at /home/benek/urbackup


From ls -l
drwxr-xr-x. 2 urbackup urbackup 4096 Aug 10 10:07 urbackup

getfacl /home/benek/urbackup/
getfacl: Removing leading ‘/’ from absolute path names
file: home/benek/urbackup/
owner: urbackup
group: urbackup

Setting the path /home/benek/urbackup results in an error
The directory where UrBackup will save backups is inaccessible. Please fix that by modifying this folder in 'Settings' or by giving UrBackup rights to access this directory.(err_folder_not_found)

Is it a problem that /home is a separate file system?
mount |grep fedora
/dev/mapper/fedora–server-root on / type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/fedora–server-home on /home type ext4 (rw,relatime,seclabel,data=ordered)

Here is the server info
Name : urbackup-server
Version : 1.4.14
Release : 3.1
Architecture: x86_64
Install Date: Wed 10 Aug 2016 07:14:22 AM CDT
Group : Unspecified
Size : 6046150
License : GPLv3
Signature : RSA/SHA1, Thu 24 Mar 2016 09:42:34 AM CDT, Key ID a48f8e42ac2d60c7
Source RPM : urbackup-server-1.4.14-3.1.src.rpm
Build Date : Thu 24 Mar 2016 09:42:18 AM CDT
Build Host : cloud118
Relocations : (not relocatable)
Vendor : obs://
Summary : Efficient Client-Server backup system for Linux and Windows

Thanks for any hints