Imagebackups and Virtualization


currently i am backing up more than 20 Clients by using UrBackup.
Now, from what i wanted to do initially was to use the created .vhd-Files to boot of those Backups in a virtual Environment (Virtualbox or VMWare for expample).
I noticed that somehow the MBR does get stored besides those vhd’s. But i haven’t figured out how to use those.

Now, is there any way to boot those images straight off? I already tried restoring those virtual machines via restore disc, but that does not work, because the restore disc fails with “waiting for partition” or something like that (can’t remember fully).

Can anyone help?

The VHD do have a MBR, just not the one which includes all the volumes (One VHD=one volume). If it wouldn’t have a MBR, you would not be able to mount it.

I think I managed to boot from a VHD. It does not work with Windows XP (Only Windows Vista or greater). The VM must be the same, as the one it was restored from. Windows does not like suddenly being on different hardware.

You should be able to restore using the Restore CD. If not it would be helpfull, if you tell me steps to reproduce the problem. Especially if you are using free tools such as Virtual Box.

Nothing very special. Created a Image Backup of some PCs i have here, and i wanted to boot them in a Virtual Machine. Virtual Box for Example (VMWare doesn’t work either).

When i use the .vhd as virtual Harddrive, the System is not bootable. I could restore them inside the Virtual Machine with no Problem. But it would be nice to know if there is any way to boot straight off the .vhd created by UrBackup.

Ok, so i tried another thing which does not work. I have copied a .vhd from my NAS (urbackup-storage device) to my local pc. I have then used the .vhd as primary hdd inside VirtualBox. When trying to boot, it failed. (as expected). I then have written a boot-cd to restore the MBR, which i did by using your example ("./urbackup_client --plugin ./ --restore true --restore_cmd write_mbr --mbr_filename /media/server/clientname/Image_C_20121221-1212.vhd.mbr --out_device /dev/sda") and my .mbr file. The script told me it would be all ready and done, and when trying to boot, it still fails with “Error loading operating system”.

Can you please tell me in which way you are writing those *.mbr files, and how i can restore them so i can boot my image backups off in VirtualBox?

As mentioned it will not work if you have a system restore partition. Do you have one?

Restoring the original MBR like you did will not work either, because UrBackup is putting the volume on a VHD-block boundary and the original Windows volume is often at some weird block boundary.
As said, Windows XP, won’t even start, if the volume does not start on a cylinder-boundary, so we’re totaly out of luck there.
As said, I once managed to boot it, but the jump adress in the MBR may be currently wrong, because I’m not testing this. You may be able to fix this by booting a windows cd and running “fixmbr” in the restore console.

But even if one manages to boot it, it will most likely Bluescreen during startup, because it is loading the wrong drivers.