Image restoration failed with - No Backup server found error

I am using UrBackup Server Version 2.0.36 on CentOS 7.
Image backup of my VMs have completed successfully.

I am trying to restore the Image backup of one of my VM and i get the error “no backup server found”.
I am using restore cd image 2.0.3-2. Tried with 2.0.2 version also, but same error.

Seems to be Network issue.
When i boot from live CD, its not taking the IP address and later when i assign the static IP also, i get the same error - Backup server not found.

Need some assistance in addressing this issue.

You need to be in the same (v)lan as the backup server. There should be no router in between.

how do you restore the image?
Do you lunch the “cd image” in the VM Environment?
Do you boot the cd in the same VM that you want restore?
I met similar issue with physical PC, in the “cd imagine bootable restoring” you have to set the IP manualy, set the same IP that “old” VM had, and try again.
I hope this could help you.

I am launching the CD image in the VM Environment.
Tried with setting the IP manually but no luck, but i had assigned different IP. As you suggested i shall set the same IP and try once again.

There is no router and i am in the same vlan.

Assigned Static IP address of the restoration client still the same issue, not able to find the Backup server.

Have tried with restoration CD 2.0.2 and 2.0.3-2

What kind of networking device does you VM have?

I have my Urbackup server on CentOS 7 running on ESXi host 6.0.
My ESXi host is connected to 24 port 3COM network switch.
My UrBackup Server IP is

Find below snap of Network config at ESXi host,

I have urBackup version 1.4.x running in the same environment on CentOS 6.6 and its working fine (File system and Image - Backup and Restoration).

We wanted to go with Urbackup 2.0.36 on CentOS 7, but Image restorations are failing with - no backup server found. Have manually assigned the static IP and tried but still image restorations are failing with same error.

did you try with an old restoring CD version?
maybe the 1.x version could have a more “easy” way to recognize the SERVER: