Image mounting failures - possible cause

All,

As some of you have experienced image mounting failures I believe I have found a possible cause. I thought it might have been a kernel issue, but it seems to be related to btrfs. After switching from btrfs (screwed me over twice) to ext4 as the storage media, image mounting now works perfectly.

When using btrfs, I could only get the image to mount if I ran “sudo libguestfs-test-tool” first. Even then it threw errors, but did eventually mount the image.

Ver: 2.4.12

Thanks,

Craig

As I kind of tried to describe it works for me now with debian and btrfs from the webinterface.

What problems did btrfs cause?

My disk filled and completely trashed the filesystem. None of the btrfs recovery tools were able to do anything about it. I could read the data, but couldn’t delete anything to free space. Disk would dismount at any attempt to write to it, delete data, or run any recovery commands.

Might have been able to add more space to the volume and run a balance, but since it was just backup data, I re-formatted in ext4.

Btrfs just seems to risky to me.

Craig

1 Like

Did you use low soft file system quota?
From manual:
You should set a generously low soft file system quota (see section 8.1.14) if using btrfs, because btrfs currently still has issues in out-of-space situations and may require manual intervention.
https://www.urbackup.org/administration_manual.html#x1-90002.1.5

1 Like

I did use the soft quota and it was working fine. However, I inadvertently kicked off a backup on a partition that contained multi-terabytes of vmdks. By the time I realized the mistake, it was too late.

While ultimately the issue was my fault, any file system that goes tits-up simply by filling the disk is one you want to stay away from.

Craig