Image Backups Failing Across the Board

I am using UrBackup Server 2.3.8 on Windows Server. File backups are working great but I have a few machines set to backup images on a daily basis and noticed that this wasn’t happening this morning. I attempted to manually run full image backups and every single one failed with the same error message for the most part:

Error opening hashfile (D:\urbackup\XXX-XXXX\190524-2113_Image_C\Image_C_190524-2113.vhdz.hash). The system cannot find the path specified. (code: 3)

Any idea on how to fix this? I’m not sure why UrBackup is trying to reference an existing file if I am trying to invoke a full image backup.

Thank you!

You can see the log of the server,and check the permissions of the directory

I’ve checked the log and the error being presented was included in my original post:
Error opening hashfile (D:\urbackup\XXX-XXXX\190524-2113_Image_C\Image_C_190524-2113.vhdz.hash). The system cannot find the path specified. (code: 3)

I’ve also checked the permissions of my D:\urbackup directory and all looks well… SYSTEM has full access to the directory and all subdirectories.

Any other ideas?

I’m not sure how it would be a permissions related issue when file backups work fine – only image backups are failing like this.

Is your urbackup service running as SYSTEM?

It appears so.

Bump, any assistance would be appreciated.

To add to this, I created a brand new directory, D:\test and changed my backup storage path to this new directory.

Then I ran a full image backup on a machine and see the following error in the logs:
Error opening hashfile (D:\urbackup\XXXX\180907-2225_Image_C\Image_C_180907-2225.vhdz.hash). The system cannot find the path specified. (code: 3)

Why is the server still trying to reference the old backup storage directory after I’ve changed it in the server and initiated a new full image backup?


Bump. I could really use some assistance please. I figured that if I just created a new UrBackup storage folder that this would solve the problem easily enough but that doesn’t appear to be the case.

Turn off synthetic full image backups?

Hi Uroni

Thank you for the reply. Unfortunately this didn’t work. I disabled full synthetic image backups here:

Then I took a full backup of a machine and it failed with the same error:
Error opening hashfile (D:\urbackup\XXXXXX\180907-2225_Image_C\Image_C_180907-2225.vhdz.hash). The system cannot find the path specified. (code: 3)

Any other ideas? I’m desperate to get image backups working again and I’m not seeing what the issue is…

Hate to be a total pain but I am still not able to resolve this issue – would anyone be kind enough to assist? I’m out of ideas of what can be done at this point :confused:

I don’t have the experience to know what is wrong but I can tell you what I would check.

Where is the path “D:\urbackup\XXXXXX\180907-2225_Image_C\Image_C_180907-2225.vhdz.hash” wrong? Check the existence of:

  • D:\urbackup\XXXXXX
  • D:\urbackup\XXXXXX\180907-2225_Image_C
  • D:\urbackup\XXXXXX\180907-2225_Image_C\Image_C_180907-2225.vhdz.hash

Does Image_C_180907-2225.vhdz.hash exist elsewhere on disk or in a backup? If so I would restore it to the expected location.

Would it work if you cheated and copied ALL the files comprising an earlier image backup to replace the missing backup?

Are you still using options that cause urbackup to refer back to the previous image? Mistakes I have made have included:

  • Failing to press save after a change
  • Changing the wrong option (eg global, group or client level settings)
  • Not forcing settings on the client via the permissions tab on the server

My expectation is that you are falling foul of 8.5.2 Transfer modes or 8.5.4 Full image backup styles both of which can cause the backup to look at the previous image backup. The former reads as if you may need to use a local rather than an internet connection to avoid hashes.