'Illegal Instruction" Error installing 2.4.8 linux client on Synology 1511+

Trying to get the latest client installed on a Synology 1511+ using Docker. I’m running 2.4.8 server on a Ubuntu machine.
Under Docker, (which is officially supported by Synology), I start the official Ubuntu image, install wget, and run:

TF=\`mktemp\` && wget "https://hndl.urbackup.org/Client/2.4.8/UrBackup%20Client%20Linux%202.4.8.sh" -O $TF && sudo sh $TF; rm -f $TF

which I copied from the urbackup.org download page. (I actually split it into two commands to make sure the download is OK before proceeding. Here’s the terminal capture:

root@Company_NAS1:/# TF=\`mktemp\` && wget "https://hndl.urbackup.org/Client/2.4.8/UrBackup%20Client%20Linux%202.
4.8.sh" -O $TF                                                                                                
--2019-10-15 14:55:34--  https://hndl.urbackup.org/Client/2.4.8/UrBackup%20Client%20Linux%202.4.8.sh          
Resolving hndl.urbackup.org (hndl.urbackup.org)..., 2600:3c00::f03c:91ff:fec8:ecf6             
Connecting to hndl.urbackup.org (hndl.urbackup.org)||:443... connected.                         
HTTP request sent, awaiting response... 200 OK                                                                
Length: 21066217 (20M) [text/x-sh]                                                                            
Saving to: '`mktemp`'                                                                                         
`mktemp`                    100%[=========================================>]  20.09M   718KB/s    in 17s      
2019-10-15 14:55:51 (1.16 MB/s) - '`mktemp`' saved [21066217/21066217]                                        
root@Company_NAS1:/# TF=\`mktemp\` && sh $TF; rm -f $TF                                                          
Verifying archive integrity... All good.                                                                      
Uncompressing UrBackup Client Installer for Linux  100%                                                       
Installation of UrBackup Client 2.4.8 to /usr/local ... Proceed ? [Y/n]                                       
Uncompressing install data...                                                                                 
Detected Debian (derivative) system                                                                           
Detected architecture x86_64-linux-glibc                                                                      
(Glibc not installed or too old (2). Falling back to Android NDK build...)                                    
Illegal instruction                                                                                           
Error running executable on this system (x86_64). Stopping installation.                                      

The processor is a 64bit Intel Atom K525 @ 1.80GHz. (Per “cat /proc/cpuinfo”)

The 2.3.4 client installs and runs fine, so this isn’t a show stopper. But if it ever auto-updates, I might have problems. I’m more than willing to help figure this out, since I have the hardware, but I need someone to point me in the right direction. Just to confirm that it isn’t docker, I spun up a VirtualBox Ubuntu 18.04 on my Win7 PC, installed Docker, installed the ubuntu docker image, ran the instructions above for the 2.4.8 client, and it ran fine. It’s either the Synology OS, or the Atom processor.

Could be the same issue as in [Ubuntu] Glibc not installed or too old

Could you try the version linked there?

I’m running GLIBC 2.2.7. I ran the http://beta.urbackup.org/tmp/UrBackupUpdateLinux(13).sh file using the published install instructions on https://www.urbackup.org/download.html#linux_all_binary. It didn’t find the right Glibc, so fell back to the NDK build and installed without error.

I ran the ‘urbackupclientctl wait-for-backend’ command that the other poster had an issue with and it completed without complaint. I just forced a backup from the server’s web page and it completed without error.

As someone who does tech support for a living, Thank you so much. I wasn’t expecting a reply for a day or two, let alone a solution. I’ll keep an eye on the other issue page. Let me know if there is anything I can do further.