I want to be able to like UrBackup - Assorted setup issues

Hi, I’m new to using UrBackup. I’m planning to get a dedicated system in the near future to use as a NAS backing up multiple computers, and UrBackup seems to come up often as a well liked solution so I decided to try it out. It’s been about 2 weeks now of trying to test it out on my local system only using an internal HDD, and the software, while seemingly easy to use at first, has been having no end of issues in my setup. To list the ones I remember off hand:

  • the client cannot change any settings, even when set as allowed by the server
  • the server does not respect the soft limit of 50% disk utilization in any capacity (will regularly fill the entire drive)
  • the server software service stops whenever it fills the entirety of the target drive (archive drive F: is utilized entirely, and then the service quitely stops)
  • The server and client are configured to only make an image of D: drive, yet the server regularly initiates full image and file backup for the C: and E: drives (which is not possible to complete due to size limitation of the testing target drive F:)
  • when the server is restarted after crashing, it looks at the target drive F: for a bit, then deletes everything before starting an incremental backup

I’m running on Windows 10, client version 2.5.21, server version 2.5.28, and presently I’m not worrying about external networking stuff; but I am wondering if I’m just using the software horribly wrong to have so many stability issues. I could never rely on this as a solution if this was normal, but other people seem to have great results with UrBackup. I’ve uninstalled and reinstalled everything a few times to no avail. If anyone has any suggestions to start working through it (I do have plenty of time to solve issues, if I have any hope they could be reliably and concretely solved) or if I should just give up and use another solution instead, that would be of much help. :bowing_woman:

When the client changes settings, these changes do not display on the web interface of the server. Those are the settings the server would use, if the client had not overridden them. And when the client does override them, this is not displayed on the servers web interface. You can see the changes on the client however. I run Linux, not Windows, and on a client I can run the commands “urbackupclientctl status” and “urbackupclientctl list-backupdirs” to see the current client settings. There’s got to be some equivalent way to display things on a Windows client, but I am just not familiar with that.

Several of your problems seem to revolved around the size of your backup drive (the one you are calling F:) It’s not enforcing a soft limit, it fills the drive then stops, it crashes then looks at the target drive for a while before deleting things. These all seem to be related to not knowing the size of the target drive or something oddball like that. Did you inadvertently do something weird in the way you specified your target drive? Again, I don’t know Windows, but in Linux you could specify a target drive using a symlink, a remote mount, or something like that. I wonder if you might have accidentally done something in the way you specified the backup drive and UrBackup can’t accurately determine the size of the drive? This theoretical possibility might explain the oddball stuff you are seeing related to drive size. Realize that I have no idea if an improper specification is possible, I’m just talking off the top of my head trying to guess some common thread that might explain several of your reported problems.

When you say the server is making images of C:, D: and E: when it should only be doing C:, make sure you are looking at the configuration from the client. Remember, the client does not update the configuration as displayed on the servers web interface. You’ve got to look from the client to see what is truly configured. It’s possible that when you installed the client, it asked you (or defaulted to) backing up all the drives that if found in existence. And this could be different than what the server defaults are as displayed on the web interface. Remember, the client settings override the server defaults, but this is not displayed on the server web interface.

UrBackup actually works quite well. But there are quite a few gotcha’s (like clients not updating the server web interface) that make you think something is broken. My take is that UrBackup is solid in the core, but the edges (the user interface) are still quite rough, even though UrBackup is a mature product. If you really want to start scratching your head in wonder, try messing around with the automatic archiving settings. And try to predict what UrBackup will choose to archive. That’s a really fun game. I’ve been playing for months, and I’m still no closer to winning.

Thank you for the response. It did take some time to figure out the difference between client and server settings, but there are a few points I should clarify about that. I have double checked both the client and server side to ensure that only drive D: is listed as an image backup option. As well, it is when I try to update client side settings that hitting save doesn’t actually save anything. I can reopen the settings to find that my settings are at what they were before I tried to change them; however, sometimes it does change, but I’m not sure what the condition for that is, or if its just luck. I can at least push settings changes to the client through the server side using the profiles. Permission is enabled for clients to edit settings, so I’m not sure what’s up there. Intermittent glitches are hard to solve. This issue also occasionally applies to the server configuration, although in most cases it simply erases client profiles that I had set up for convenience.

Another thing I’ve noticed just using it now is that while I have the client side application disabled while I debug the server, the server still initiated image backups of C: on its own. Still no hint of such an instruction in the settings.

As for UrBackup not understanding the size of drive F:, that does make some sense to me as a possible cause, although how it could happen I do not know. I’ve decided to try reformatting the volume, although I’m certain I did that before using it anyway. I’m not sure what could be causing such an issue, I simply used windows disk manager to handle formatting.