How to repair database?

Hello there!
HD partition was filled, Urackup alarmed the place is out. I stopped server, cleaned some files and start server.
Server log:

2020-11-14 10:34:47: WARNING: SQLite: no such table: directory_link_journal in “SELECT linkname, linktarget FROM directory_link_journal” errorcode: 1
2020-11-14 10:34:47: ERROR: Error preparing Query [SELECT linkname, linktarget FROM directory_link_journal]: no such table: directory_link_journal. Retrying in 1s…

and not started.
urbackupsrv -repair-database - not helped
copy backup-server.db & backup_server_setting.db from backup - not helped
What can i do ?
If i reinstalling server will it catch old archive or drop it as unknouwn ?

Any help

Try running the remove-unknown script, it should remove references in the db to files that aren’t there anymore, hopefully, that might get things back functioning.

If server have been reinstalled, will its database known nothing about old archive. and, logically, archive db will be dropped ?

I’d guess it’d start with a new (empty) database, it should be possible to restore the old one from the nightly backup it makes of the database.

From the sound of it you’d then have to either repair that and/or remove unknown to get that referencing the files there.

If you ran remove-unknown against an empty database it’d probably delete existing backups, so don’t do that.

Simply reinstalling the server probably doesn’t recognise anything in the backup storage, or any existing clients without extra steps, I’ve not tried it.

What is the old nightly backup do you mean? backup_server.db and backup_server_settings.db ? I have been tried remove current files and copy backuped. The error remains.

Well I’m really not that expert, but in your situation, I’d try using those, then running remove-unknown, regardless that the server doesn’t start normally, the first thing that script does is stop it & start it again in a different mode…

If that failed, I’d be resigned to waiting for someone with more skill, or just starting over from scratch.

I’d be figuring I can’t break it worse at this point, & backups are easily recreated, just back up again, but that’s me.

At this point, you might be having to start over anyway.