How do you force URBackupServer use a particular ip address for a client?

My Setup is 2 x URBackup servers, one on windows 7, the other on Windows 10. There are 6 machines to be backed up, all on wifi, and 5 on wired ethernet as well. (both are 2.3.8)
The windows 7 server chooses to use the wired ethernet except for the one machine that has only wifi. This is what I want, since some of the wifi connections are not fast.
However, the windows 10 server chooses wifi for all machines, and full backups can run for days. If I turn off the wifi, then urbackup will eventually find the ethernet and use that, but if I turn the wifi back on, it will decide to continue with the wifi.
While I think this is an issue with Windows 10, is it possible to tell UrBackup to use a particular IP address for a client, and so choose the ethernet over the wifi?
I tried using the server hints, but that doesn’t seem to have much effect.

While dropping the wifi connection works, it isn’t all that practical, since the wifi is the connection to the internet, and is in use during the day.

I controlled a similar problem by setting the windows firewall to block traffic on the wifi ports.

In the windows firewall for the UrBackup rules’ properties go to the “Advanced” tab and select “Customize” in the “Interface types” section. You can then block the port for wireless.

I did this on a client but I guess similar could be done on the server.

Binding the server to a single IP would be neater but using the firewall to block the wifi for UrBackup would work.

Thank you or the suggestion. Binding the server to a dingle ip address for the client would be my preferred option, but this will work.

For the record, the client process listens on port 35622 UDP


I’m pretty sure that’s due to Microsoft seriously breaking how it handles traffic in 8+. Instead of prefering the fastest link speed, it seems to prefer the most recent connection (almost always wireless). I’m just going from experience, not any knowledge of the guts of windows, but I do remember all sorts of hassles with 8, which continued with 10.

Assuming you want ALL traffic to prefer the wired connection, you could have a look at the “metric” setting on each interface… Assuming windows 10 still lets you set that - I haven’t used windows for over 12 months because it drove me nuts with supply issues like this.