How do I restore?

Trying to archive one backup before i wipe and reuse the drive that the backups are currently saved to. I tried restoring using the restore CD and a VM, but keep getting a message that there’s only 1 k available on the 1.2TB drive (tried iscsi and VMDK). So I looked in the docs and see that it says:
“right-click on the UrBackup tray icon and then click “Access/restore backups” which opens the browser, or they can right click a file/directory in a backup path and then click on “Access/restore backups” to access all backups of a file/directory (only on Windows with Windows Explorer).”

I have neither option. If I right click the client icon I don’t get a ‘restore’ option of any sort, and if I go to the URBackup server web interface, all I can do is click on each backup and either drill down and restore an individual file, or ‘download as a zip’ which I don’t think I want to try to create a 900g Zip file…

Am I missing something? It seems a great backup, but if I can’t restore anything (other than by creating the aforementioned giant zip file), it’s knida useless, so as I note, I MUST be missing something… right??

Again, my goal is simply to restore ALL the files from one of the backups to an external drive (or NAS or whatever). If there’s a simple way that I’m missing please let me know!
(Working on Windows 10).

Thanks for any suggestions or input!!


OK, I’ve gotten a little further, realized that I didn’t have the ‘server url’ set, so I set that, and now I see the access/restore backups. On my system when I hit that it gives me an error “error getting server url. Cannot access file”. So I tried it on a client system, and it didn’t get the URL error, but the only restore option is to restore the folder to the original location on the original machine.
Is that the only option? Is there no way to restore from a different system (since the original is retired) and to a different location?

I am interested to know the answer as well as I am planning to move from windows to linux and need to have most of my backup back on it.
If you find a solution outside this forum, can you please share it?

If you can attach the disk drive you are using with Windows to the new Linux system, you can copy the settings and history from the previous UrBackup installation to the new one, as described in my reply to your other message. Upon restarting the Server in the new installation you will need to fix the backup storage path to reflect the mount point of the old storage drive on the new system. After that you can use the method described in 10.8 Migrate non-btrfs backup storage to move the backups from NTFS to a more suitable Linux filesystem.

If it is not possible to move the current backup volume, then migrate the backups first to a large portable drive, then attach it to your new system and migrate once more as described above.

I read the article.
In the documentation, it keep mentioning /var/urbackup as you also reffered in the other post.
Since I use a docker, when I look in the /var of the machine, there is no urbackup folder.
At that point, I get lost to how restore a backup (file backup) to a new installation nd even on a different OS and file system.
The scenario is:

  • URBackup runs on a OMV docker
  • client is windows to migrate to Linux
  • restore all files (non system files) from backup to new OS (documents, or any other files other than system)
  • new device has new urbackup client.
    -Server disk cant be moved around (is screwed onto a surface and attached to the Raspberry pi)
    how can I get all my files back?
    I would imagine that a backup system assumes such a situation for restoring files.
    If above is not working, would be the only solution creating an IMAGE file and mount it on a client machine as a virtual machine disk, and than copy over the files?

    Sorry for the elaborated question.
    I hope I manged to explain correctly what is the situation and the question.

Much appreciate your help

In other words, I need to understand if the backup is useful for a restore on a different system, and how.

WinSCP shows that the files backed up are actually readable.
Maybe it is possible to map the backup folder… changing permission on the folder and accessing it using SAMBA.
Could be that a solution?
The fact that is readable is an advantage.
The problem will be to understand the incremental backups and use the latest files and additions.