Home Directory Opensuse


#1

Hi I searched to see if I could find this topic but i have not been able to find this specific question.

I am running Urbackup server on Ubuntu 18.04 LTS with UrBackup Server v2.3.7.0

The client I’m backing up is Opensuse Tumbleweed with client version 2.3.4

It does the discovery just fine, and i’m seeing it in the server console.
I set the default backup directory to be just ‘/’

When i go in and look at some of the directories below ‘/’ in the full backup. Such as /home

It did grab and create the /home folder but it did not grab anything below that such as ‘/home/john/xxxFILESxxx’

Could anyone tell me why this is happening like this? I have read through some of the documentation but I honestly dont know what topic i’m searching for to troubleshoot this. I was hoping someone could answer my question or point me in the right direction. I dont mind doing the reading. I just have no idea what topic i’m looking for to resolve this problem…


#2

I don’t think it s a good idea to use such setting.
you d need to ignore /proc /sys /tmp /dev and any virtual filesystem.
Possibly ignore /var/log as well

Also, possibly , you want to look at virtual client in the doc and set up a separate one for /home/ so /home has daily backup , and the the rest has a weekly or monthly backup

Also please look at clients and server logs for errors


#3

/home is probably a different file system/mount. You’ll have to add that separately to the backup, currently it does not automatically backup across file systems.

(I know that this needs to be improved…)


#4

Sorry Orogor,

I didn’t put in there that I did implicitly ignore those directories as well as /mnt and a couple others.

And Thank you for the advice. I will take a look into your suggestions.

That looks like a far more effective way to backup my machine that just using /


#5

Thank you for the Reply Uroni! I was just trying to figure out what i was doing wrong. That helps alot!