Help - Incremental cleanup issue - recent backups deleted


#1

Here’s the scenario:

Client server (VM) crashed 2 days ago and needs a full image restore.
UrBackup image backups successfully ran the night before the crash.
Attempted to work on the file storage system today to see if we can boot the server (VM) but no luck.
Looking through the UrBackup web interface today it shows in the “Activities” section a listing of “Deleting incremental image backup” multiple times as though the cleanup window job ran.
Went to the “Backups” section and all recent incremental backups for the past 2 weeks are completely gone.
The only incrementals left are from before 2 weeks ago which go all the way back to May of this year which also has the last Full image backup.

Does anyone know why the cleanup window would remove 2 weeks worth of recent incremental backups but keep such a large amount of older backups?

UrBackup Server 2.2.10

Retention settings for Image backups set as follows:


#2

Sorry, that is bad. My guess is it fails to delete the older images for some reason. Details would be in info level logs of the cleanups.


#3

How do we go about getting those logs?


#4

#5

Uroni,

Understood but I was unable to find a similar instance of this issue from searching the forums today. Also, is there a private location that I can send you the logs in case you can look at them?


#6

It is a link to a post. You should read the whole thing…


#7

Thanks for sending the logs. Cannot see the problem yet, though. Could you run a cleanup (or wait for one), preferable one where such an image gets deleted and send me a debug log of that? Thanks!