Heelp needed - Wrong storage usage evaluation after out of space situation

Hi All ,
Ubuntu 18, urBackup 2.4.13, Disk ~2TB

Backup folder was on same disk as system , and several days ago i ran out of space, so had all those messages about corrupted DB , and several other issues popped up.

To free some space i have removed several older folders from “hosting3” bakcup inside of backup folder (which looks like 210601-0132, etc) and ran several times

service urbackupsrv stop
urbackupsrv repair-database
urbackupsrv defrag-database
urbackupsrv cleanup --amount 50%
urbackupsrv remove-unknown
service urbackupsrv start

This did the trick , cleared half of the space (so i have ~1TB availiable now) , however when i first deleted the files - stats went crazy and showed im using 13TB of space (even tho i have 2TB ) . After all scripts - the situtation is the same. The bakcup i manually deleted shows usage of 11TB. (see image) .

What can i do to fix this ? Any ideas ? Thanks !

Had to remove whole bakcups form files , and rerun remove unknown and repair database . This solved the situation (tho left me whithout bakcups)