Headless ubuntu client not backing up

I followed this tutorial to setup a ubuntu client and stipulated the headless option. The “File Backup Status” column lists “No paths to backup configured”

Within the settings tab on the server I have “Separate settings for this client” is set for the client in question. Additionally “Default Directories to backup” is set to “*”.

What do I need to do to create a complete backup of this machine running ubuntu?

Thanks so much!

Try setting the default directories to “/”.
You’ll probably also want to exclude some common paths that aren’t really files as such - “/proc;/dev;/sys”. Depending on your needs, “/tmp” is another one you may want to add to the exclude list.

@tin, thanks for the response. I did try that, unfortunately it still won’t back up. Thoughts?


for me this worked:

sudo urbackupclientctl add-backupdir -x -f -d /home

To view which directories are being backuped:
urbackupclientctl list-backupdirs

Kind regards

Listing the backups helped to track down an error that didn’t make sense. Apparently I had one path set to “*”. Once I removed that it seems to be working now. If it continues to fail, I’ll check back.

Does anyone have any idea how to exclude a directory from the command line? That seems to be the next hurdle I face.

im following the same instructions as you are to get headless up and running but im not sure where youre seeing “stipulated the headless option” i follow the tutorial right to the bottom but


gives me an error:

Unable to init server: Could not connect: Connection refused
17:00:18: Error: Unable to initialize GTK+, is DISPLAY set properly?

how do i specify headless?