Having issues with UrBackup server connecting to the mail server- see examples below

With out user name and password, which works internally on our network-

Sending test mail failed. Error: Failed sending data to the peer(ec=55), RCPT failed: 501

With admin user and password-

Sending test mail failed. Error: Login denied(ec=67),

We are using the most current version of UrBackup, version 2.0.38

Any help anyone can provide would be great.

Thank you.

On a Linux machine, not sure what you use, I only had to fill out these settings:
Mail server name
Mail server port
Sender email address
Server admin email

On a local network you can just pass it to your mail service (postfix here) and it will do everything else.

We are using a Windows 2012r2 server as the HOST for UrBackup.

Can you try with username but without password?

Tried that too with no luck;(

All of our other web apps and client server apps can connect to the local email server fine without user name and password. I stumped… I’ve tried every configuration and NO LUCK:(

I RESOLVED the issue. Please disregard.
Needed to be set a specific way.

If someone has the same problem I am sure they would appreciate having some hints how to solve it…


Hi, m8! What was the solution? I have the same issue

So far, if anyone is interested th solution was extremely simple:
On the “Send test mail after saving the settings (leave empty to not send a test mail)”: you should put EMAIL not test message!! That is not really clear from interface and not clearly explained in admin guide.

I beleive it’s somehow better managed in english version, but in russian interface it does not mention email address


I had the same issue and this reply helped! Thanks!

Hi, when I try to send test message, I got error “Failed sending data to the peer(ec=55), RCPT failed: 501”. When job finished, urbackup didn’t send any message to admin email. Please help me fix this problem. Thanks

Same trouble. May be somebody find solution?
Ubuntu 18.04, urBackup Server 2.2.11

Had the same problem, here’s how it got resolved:

My ermail server setting were correct. I used the the dummy email address “urbackup@mydomain.pvt” for the Sender E-Mail Address because 1) The alert would be easier to sort by address in the masses of email I get every day and 2) I didn’t think it mattered. It did.

After changing the Sender E-Mail Address from urbackup@mydomain.pvt to a real email address (my personal email), I got tons of messages in my mailbox, leftovers from previous tests. Problem solved.

If anyone cares to test this or duplicate it, I’d appreciate it because, after all, I’m just one guy with one computer and YMMV.

BTW, SMTP Error 501 is (according to https://sendpulse.com/knowledge-base/smtp/invalid-email-address-error-codes):

SMTP error 501

Error 501
HTTP 501
501 Not Implemented
HTTP Error 501 Not implemented
The server either does not recognize the request method, or it lacks the ability to fulfill the request.
Command is correct and recognised, but the parameters were invalid. You may receive this error when sending to invalid email addresses or to an invalid domain name. Also, it may be caused by drops in communication and problems with antivirus settings.