Getting UrBackup to Backup to Synology NAS

Hey ya’ll. Got a question about how to use a “Backup storage path” that leads to a NAS on my network.

I’m trying to get UrBackup to use a Backup Storage Path that leads to my Synology NAS.

Background Info:
I’m running the latest UrBackup (version 2.3.7) in CentOS 7 (which is running in a VM with limited storage capacity). This is a completely clean, brand-new install.

What I’ve tried:
I created a User on my Synology NAS called “backupadmin” and gave it sufficient rights to access the share where I want my backups to be dumped by UrBackup. Then, in CentOS I created an admin called “backupadmin” with the same password as the user on the Synology NAS. Finally, in CentOS I also created a mountpoint to my NAS using the following command:

mount.cifs //synology.mydnsname.tld/Backup/urbackup/ /mnt/synology/ -o user=backupadmin,pass=mypasswordhere

I tested this mount and it works perfectly in CentOS (i.e. I can go there and see files on my NAS, and I can write to the location).

I then logged into the web interface for UrBackup, navigated to settings and entered my mountpoint (e.g. /mnt/synology). When I click back to the Status tab I get the following error:

My troubleshooting method:
I also tried to mount with the IP address of the NAS rather than the dns name (e.g. mount.cifs //xx.xx.xx.xx/Backup/urbackup/ /mnt/synology/ -o user=backupadmin,pass=mypasswordhere), but that didn’t help.

I also scoured the web for leads, information and the like. I read the following post:

but I’m not sure it applies to this issue as I can’t change the user UrBackup is running as (plus the instructions in the post are for UrBackup running on a Windows Server), and the User on the CentOS server running UrBackup is already the same user that has access to the folder on the Synology (even has the same password).

I’m pretty stuck here and would appreciate any assistance.

I think you can install/run Urbackup on the Synology natively. Do that.

Trying to get Urbackup to use a remote file system is going to be temperamental at best…unless you’re going to iscsi mount the remote share to the local system. nfs/cifs/ftp are not feature-rich enough to allow Urbackup to do the sym/hard links necessary to work efficiently/work as designed.

NFS should work.

SMB should work with a complete implementation, e.g. if you use it with Windows to Windows (samba and e.g. netapp haven’t implemented the required symbolic link extensions yet).

i have the same issue.
any idea? i don’t want to install urbackup on my synology.
urbackup should store backups on the nfs share of the synology.

have anybody configured this? if yes, how? :slight_smile:

is read this topic very often in this forum - i think, we should write the solution down for other people.

urbackup-server: Debian 9.11
urbackup-client: Debian 9.11
Backup-Destination: Synology

Create files as root works withoud any issue, only user “urbackp” have problems.

IP_SERVER:/volume1/Backup/urbackup /media/BACKUP/urbackup nfs rw,async,hard,intr,noexec 0 0

2019-09-30 13:33:41: ERROR: Could not create or read directory for client “SERVER_NAME”. Permission denied (code: 13)

thanks and regards

i solve the issue with:

chmod 77 /media/BACKUP/urbackup
chown urbackup:urbackup /media/BACKUP/urbackup