Full File Backup of 95.6GB Takes 45 Hours. Is this Normal?


#1

Server 2.2.8, Win 7 x64.
Client 2.2.5, Win 7 x64.
Client is limited to 120 Mbps, or about 12MB per second.
Gigabit Ethernet.

100GB / 12MBps = 2.32 Hours.
A Full Image backup of this client always takes less than 3 hours.

I am mystified as to how the Full File backup can take 45 hours.

Please Help
Thank You


#2

Have u got LogFiles or Debugfiles? This is not normal. Same duration if u start it again?


#3

Hi Coraline,

I started it again and it’s been 10 hours now to complete 30%…
It looks like it will take many more hours to finish.
I will post the log when the backup is done.

Thank You


#4

you can try to uncheck background priority in advanced tab

on client , check the backup is not paused (it just trickle the backup to super low speed)

and run this command to disable congestion prevention
netsh interface tcp set global ecncapability=disabled


#5

Have u try to send a large File to the Backup-server manually? Whats the speed to transfer?
To test, if the client got a global problem or not.

Then if u identificate its only urbackup with this lowspeed, uninstall client complete and reinstall (yeah thats fishy, but sometimes it works)

Have u got a max. Backupspeed set under server client tab? Same problem if u set it to 12 MBit/s?
Fany firewall or fancy antivir? Like BitDefender is horrible in my opinion.


#6

But that screenshot shows computer “buzz” currently uploading an image at 62 Mbit/s. The other clients have their file backup slowed to a crawl. Looks to me like a 100 Mbit link completely saturated. Are you sure the Urbackup server has gigabit ethernet up to and including the nearest switch/router?


#7

Hello All,

Orogor:
Background priority has never been checked.

I have six clients. They all respond this way.
None of the clients are paused.
Everything is gigabit Ethernet.

ECN has always been disabled on both the server and the client.

I do not know what the autotuninglevel message refers to on the server.
All values in both shows are identical except that the server has the autotuninglevel message.

Coraline:
I copied a 4GB ISO file from a drive on the Muff client to the backup folder on the server’s drive.
It did 30MBps (300Mbps) all while an image backup was moving at a respectable pace and two file backups were crawling along.
Also, please notice the glint display at the bottom of the screenshot.
The file copy pretty much maxed-out all four cores of the processor.

Following is a screenshot of Glint during normal operation without the file copy.

UrBackup uses some 30% CPU or less all of the time.

All clients are limited to 120Mbps (12MBps) and the server is limited to 360Mbps (36MBps).
The server is also limited to 3 simultaneous sessions.

Windows firewall everywhere with Avast antivirus on the server (Zeus) and MS Security Essentials on the client (Muff).

I have not yet tried reinstalling a client. It is more difficult task when you have two UrBackup servers.
I do not have fond memories of installing the clients.

JFlapjes:
Everything is gigabit Ethernet.

Zeus and Buzz are UrBackup servers.
Zeus backs up Buzz and five other clients.
Buzz backs up Zeus and those same five other clients.
For some reason Toad never appears on Microsoft’s network map but it is plugged into the same switch as Plum.

Thank you all for taking interest.


#8

Hi

Could it be that you backup the client on two servers at the same time ?
I noticed much slower backup if i backup from two severs at once
Than if i backup to one server than to another one


#9

Hello All,

Oregor:
Yes, it is possible that one client might be uploading to two servers.
I will keep this in mind now that I know the answer.

Brace yourselves, here it is.

I disabled Avast’s real-time protection on the server (zeus).
Within seconds the servers hard drive light wound up to 99% and held that for five hours until all of the work was done.

Whooda thunkit.
I might never have tried the antivirus if not for Coraline’s firewall/antivirus suggestion.
Thank you.

But now, does anyone know how to fix this?
I don’t want to leave Zeus with no real-time antivirus protection.
Zeus is using the latest version of Avast Free antivirus.

Thank You


#10

Hi

You can try to make an exeption rule for the process.
Usually AV allow you to do that, either per process or per folder/file


#11

You could also change the AV software client on Zeus to something more robust, maybe there is an issue with urBackup and Avast.

Also you could exempt the backup directory from realtime scans, but do manual scans on a frequent basis.


#12

I chose to exempt the backup directory from real-time scans.
Now, UrBackup moves quickly.

Thank You


#13

i have found that for some reason on the client side when compoments is added the server takes forever to do a full backup or even just an incremental