Force Backup over Private IP


I have the following on the URBackup Server and the same on Client servers

Public IP
Private IP

when we do a backup / restore it wants to go over the Public IP, is there a way to force it to go over the Private IP?

As I understand it, if the client and server are both on the same subnet, it should do so. OTOH reasons why it wouldn’t would be private IP addresses on different subnets, or a firewall interfering with (blocking) the UDP broadcasts UrBackup uses for a client to discover the server.

That said, if you go to settings on the client, and uncheck the box allowing internet backup in the internet tab, that should solve it too.

If the private IP addresses are on different subnets, then you have a more complex problem to solve requiring a more in-depth and creative solution.