Feature Request: Discover Backup Server via DNS SRV Record

We have a lot of client networks, and I’m not looking forward to put the backup server into all of them to get broadast discovery to work. Adding clients manually is also not an option for us.
So it would be pretty cool if the clients would be able to discover the server by querying a DNS SRV record, e.g. _urbackupserver._tcp.example.com. And, if the record exists, stop the broadcasts.


That would be easy to add, but it may not help in your situation. The server connects to clients discovered via local network. If the clients are in a separate network it cannot connect to the clients.

For that you need the Internet mode, where the connections are from client to server. To get the clients to connect to the correct UrBackup server with the right credentials we have been using this script https://urbackup.atlassian.net/wiki/display/US/Download+custom+client+installer+via+Python for now.

Adding discovery of an Internet-mode server and adding a new client via DNS might be a better option. I will think about how this could be added.

Ok, i see. Well, I’ve put my server into 12 VLANs now, without any issues. It’s the easy things which never work :smile:

But now on all clients I see this error message:
2015-09-21 17:24:27: urbackupserver: No available slots… starting new Worker
2015-09-21 17:24:27: ClientService cmd: STATUS#pw=qjUH9mnmwJg168FD5fZOQuF1LbXKfp
2015-09-21 17:24:27: Created new database connection for urbackup/backup_client.db
2015-09-21 17:24:27: rc=0 hasError=true state=0

And on the Server:
Connecting to ClientService of “testclient1” failed: Sending Identity to client “testclient1” failed. Retrying soon…

Any idea whats up?

The client log indicates no error. The server cannot connect to the client. The used ports are listed here http://www.urbackup.org/administration_manual.html#x1-720009.3 . You could check if this is a firewall etc. issue by using nmap or trying to connect to the client on port 35623 via telnet.

It also does not set the interface when connecting to the client. This could be a problem if the 12 VLANs you have don’t have different network masks.

Ok, got it to work, “something” changed the subnet masks of my additional interfaces. And i had to adjust the interface order.

For those who are interested, here is how to configure a multihomed Windows backup server:

  • Team your adapters if you want link aggregation. Configure your switch accordingly
  • Put the switch interface(s) into all VLANs you need (the networks where you want backup)
  • Create your virtual interfaces and assign the VLAN IDs
  • On the “main” interface (the server network), assign IP Address, Gateway, DNS Servers etc.
  • On all other interfaces (used for backup, only assign IP and subnet mask, nothing else. Additionally disable LMHOSTS resolution
  • Change network interface order to: main interface on top,followed by the additional interfaces, then physical interfaces
  • You do not need DNS records for the additional virtual interfaces