FATAL ERROR- Writing to VHD-File Code 665

I have a user who is running on UrBackup Client v. 2.0.30 (Windows 7 Pro 64-bit machine) and my server which is running Urbackup Server v. 2.0.31 (Windows 7 Pro 64-bit). When i try to run a full image backup on their machine the backup will begin and get to about 50% and then error out. I have tried kicking the backup off on the clients machine and the server end with the same result. The error i get is the following on the server logs for that user.

I have disabled NTFS compression on their machine and shutdown and rebooted 2 times for good measure before trying to start a new full image backup. I am still getting the same error. The VHD file being created from the backup is about half the size of the users machine so it is backing some of the machine up but then erroring out before finishing the backup.

Just a guess but it sounds as though the server clean up operation caused the failure. Try turning it off…

I also notice the words ‘file system limitation’.
What file system is used to store the backup data?

I have the clean up window set to 1-7, 6-7 which is Mon-Sun, 6am-7am which does not interfere with my backups as they are set to run from 6pm-5am. Also i have tried running the backup for the client manually after the cleanup window hours during the day and still having the same issue. The server is running Windows 7 Pro 64-bit with Urbackup v 2.0.31. Urbackup on the server backs up to an external array that has well over 2TB left in free space.

Could you run contig from https://technet.microsoft.com/en-us/sysinternals/contig.aspx?f=255&MSPPError=-2147217396 on a VHD file left over from a failed backup and post the output. That is:

Contig -a Image_X_…vhd

What file system does the external array use?

Windows 7 Pro 64-bit, it just shows up as an external drive on the server, the U:\ drive.

Here is the output of running contig -a on the VHD failed file. Also the backup got to 73% this time before failing with the same error as before.

So the system containing the external array is running Windows?

I have a machine running Windows 7 Pro 64-bit which is the Urbackup Server. Inside that machine I have 4 4TB hard drives that are setup as a Raid 1. That Raid 1 is my U:\ drive under “My Computer”. It is 8TB of storage. Inside Urbackup Server settings Urbackup is set to backup to the U:\ drive. There is no operating system on the U:\ drive, it is just setup as a Raid 1 and that is all. Sorry for using the word array, i have multiple Urbackup servers and some have external hard drives they backup to and this partiular server has the hard drives internally.

Take a look at the 8TB array and check to see what file system it is. The only reason I ask is that some file systems have file size restrictions.

The file system is NTFS

Well that answers my question. NTFS shouldn’t be a problem.

For some reason the file is horribly fragmented. It seems Microsoft fixed this with Windows 8/Windows Server 2012. Here is a hotfix for older Windows systems: https://support.microsoft.com/en-us/kb/967351

It seems you need to reformat the drive with a special flag after applying the hot fix.

If it were my server I’d ditch Windows and install something that supports better file systems. But that’s just me. I’ve never really been a Windiws fan.

Obviously if you need Windows for other reasons that’s a no go.