Everything worked once, then, it stopped?

Hi All,

I have my UrBackup Server on a server here at my house, and I have one single client out in a datacenter. I am attempting to configure things and the first try right off the bat everything seemed to work. I got 99% of a full backup completed before a single log file that had changed caused it to error out.

  • Running 2.4.15 server and client.
  • Server is Debian
  • Client is Ubuntu
  • Backup configured for File backups.

My first backup run seems to have worked ok until the changed log file caused an error. Now I cannot even get my server to stay running. For sure my home firewall is blocking your update process because you are hosting via http and not https.

2022-08-06 17:13:18: ERROR: Error while downloading update file from http://hndl.urbackup.org/Client/2.4.11/update/UrBackupUpdate.exe: HTTP response code said error(ec=22), The requested URL returned error: 403 Forbidden

I manually downloaded that EXE updater via https and placed it in /var/urbackup, but that didn’t work. The above error just repeats.

Things I have tried:

  • Completely disable IPv6
  • Removed and recreated clients
  • Completely disabled the local firewalls

Not sure what else I can try. I am open to any help anyone can provide.


Additionally here is the status of my server service:

● urbackupsrv.service - LSB: Server for doing backups
     Loaded: loaded (/etc/init.d/urbackupsrv; generated)
     Active: active (running) since Sat 2022-08-06 17:39:58 CDT; 4min 42s ago
       Docs: man:systemd-sysv-generator(8)
    Process: 81984 ExecStart=/etc/init.d/urbackupsrv start (code=exited, status=0/SUCCESS)
      Tasks: 22 (limit: 154362)
     Memory: 6.8M
        CPU: 63ms
     CGroup: /system.slice/urbackupsrv.service
             └─81991 /usr/bin/urbackupsrv run --config /etc/default/urbackupsrv --daemon --pidfile /var/run/urbackupsrv.pid

Aug 06 17:39:58 machine systemd[1]: Starting LSB: Server for doing backups...
Aug 06 17:39:58 machine systemd[1]: Started LSB: Server for doing backups.

But in my urbackup.log it says:

2022-08-06 17:39:58: WARNING: Shutting down (Signal 15)


Additional log message from the Client:

2022-08-06 17:45:56: ERROR: Token id for group “urbackup” not found