Error code 665 while trying to backup VHD Image

When trying to do a backup on some clients I get this error:
“FATAL: Error writing to VHD-File. The requested operation could not be completed due to a file system limitation (code: 665)”
“FATAL ERROR: Could not write to VHD-File”
“FATAL: Writing failed after cleanup”
“Backup Failed”

Now there are about 3-4 clients machines that this happens to with the same error but I have about 20 others machines that backup fine. I have file backup disabled as I only do image backups. I have checked the backup location on the server and confirmed I have plenty of space. I have tried starting the backups manually and they error out manually as well. Also there are times where the backup will start for these 3-4 machines and it will begin backing up and then randomly error out with the above image. It will sometimes get to 90% backed up and then error. It seems this error is very random and I cannot pin point what is causing it. Any ideas?

It should actually trigger following more detailed error message, but sorry it doesn’t:

The filesystem is returning the error code ERROR_FILE_SYSTEM_LIMITATION. This may be caused by the file being too fragmented (try defragmenting or freeing space). This can also be caused by the file being compressed and too large. In this case you have to disable NTFS compression. See for details.

If you are using Windows Server 2012 use the dedup instead of the compression, otherwise use VHDZ.

I am running the server on a Windows 7 Pro machine. The VHD files are being backed up a to Raid 10 array in the machine with plenty of space. I do not have compression turned on, using non-compression VHD.