Error adding RAID Metadata device

I’m trying to add a couple of mirrored SSDs for the RAID metadata. I stuck the first one in the server and booted it up. It sees the drive and asks if I want to add it. But when I select add it as a RAID metadata device and type YES to confirm the format, it throws an error “Error while formatting device. Formatting cache device”. I tried putting in the other drive and it gives the same error. Both are brand new drives. Any insight?

Add them both at once. Then on “+use device” you can select the other one as mirror.

Don’t click on “Add another mirror”. It currently allows adding a single disk as mirror multiple times and this causes issues.

Thanks…I tried that and it still didn’t show the 2nd drive as an available mirror. I then noticed there was a system update available so I tried updating. After the update the 2nd drive showed up correctly as an available mirror and I was able to add them.

Interestingly, the system is still reporting that it’s on 10.14 and that 10.16 is available to update to. But when I tried to update before and watched the live log it looked like it succeeded.

I hope you managed to upgrade, or it realized it was updated at some point.