Enable SSL on Debian 9 Stretch


#1

Dear Urbackup forum members,

I’m currently testing Urbackup as Backup Server and Client installtion on Debian 9 Stretch. I didn’t configure the Debian myself as I joined the company recently. So I tried to config lighttp first, but for some reason lighty won’t work at all. No problem, we have a working apache server installed.

So I worked myself through the manual and configured the new mod_proxy_fcgi within apache2.4.x as suggested by Dominic Pratt in this article:

https://dominicpratt.de/urbackup-ssl-aktivieren-unter-debian-stretch/

So I basicly added the line

ProxyPass “/x” "fcgi://127.0.0.1:55413

to the proxy.conf in the mods-enabled folder under apache2. I added the line inbetween the IfModule mod_proxy.c and /IfModule statement.

I also entered the command

a2enmod proxy_fcgi

and it returned:

Module proxy already enabled
Module proxy_fcgi already enabled

Unfortunatly I cannot open the website under https://myserverip.urbackup. The server just cannto find the site. My softlink is in the folder /var/www where also other folders with website content are located.

The folder /usr/share/urbackup/www was chowned to www-data:www-data . I am a little bit out of practice with my linux skills and could use a good advise on how to proceed and or how to configure in Stretch.

All answers well be very much appreciated. Kind regards, MisterX.


#2

I have not done any administration of Apache for many years, so I can’t help you there. I have forgotten about everything that I once knew. But I might suggest that, unless you are bound to Apache, you might want to investigate NGINX instead. For things like reverse proxies and SSL I find NGINX easy to configure. Much easier than I remember Apache being. It gets even easier if you already know Docker. There is a very good Docker image … linuxserver/letsencrypt … that is NGINX webserver and LetsEncrypt SSL cert management. Docker (if you are familiar with it) makes it easy to quickly spin up NGINX and play with SSL and reverse proxying UrBackup. I use this linuxserver/letsencrypt image to proxy many different applications and add SSL to them (although admittedly, not UrBackup specifically).


#3

@MisterX What worked for me was installing libapache2-mod-fastcgi package, but as it’s not in current repository, you need to use from older version of Debian (should be in Jessie (Debian 8)). I use Ubuntu, but it works basically the same. I would also disable the proxy module. I assume you already configured ssl certificates and other things anf that problem is with fastcgi only. If not, follow the whole procedure i mention at the link at the bottom.

#add old repository
nano /etc/apt/sources.list
#replace ubuntu by debian repository
#add the following to the file, save, quit
deb http://archive.ubuntu.com/ubuntu xenial main multiverse

apt update
apt install libapache2-mod-fastcgi

#Or download the package manually and install using dpkg -i package_name

nano /etc/apache2/mods-available/fastcgi.conf
#Insert the following to the file fastcgi.conf
FastCgiExternalServer /var/www/html/urbackup/x -host 127.0.0.1:55413

a2enmod fastcgi
apachectl configtest
reboot

#If this does not help follow complete procedure as described at the following link. It’s in Czech, so either translate with Google translate or only follow the commands. https://bednarik.it/jak-nainstalovat-urbackup-server-na-ssl-https-ubuntu-18-04/
#Libor


#4

Thank you Libor and haertig,

I had to reject both solution approaches as the backup software is going to be installed on an productive application & webserver. So I’m searching for a fast to install and minimal solution. Also including the xenial repository from ubuntu is not practicable for this reason.

I found a more practicable solution for me, because I only have to backup several folders from my application server into AWS. Urbackup seems rather suited for multi client backup, cloudberry backup is my preferred choice. Still the urbackup developers should update their installation guide for debian 9. I could have used it. Thank you for your help, though. Kind regards, MisterX.