Email Notification Problem


I’m doing an email test on a windows server. But i got this error:

Sending test mail failed. Error: Login denied(ec=67), Access denied: 501

I have tried all possible combinations to make it work. But nothing. I used to test UR Backup 2 years ago and i remember email notifications worked well.
On the same server i have an other application that use email notifications and they are ok.
The mail server is exchange 2010.
Did you have any suggestion for this issue?


Can you get us a screenshoot of your settings or atleast tell us what you put where in urBackup?
On the Exchange have you made a send conector for the IP or do you use username/password?

Thanks for the reply.
Well, as i said before. This server has another app that use email notifications. And works great. So from the exchange side i think is ok. But i also tried to add manually the server ip address to the send connector. Nothing changed.
On the URBackup settings i have configured only those:

Mail server name: my exchange server
Mail server port: 25 (i have tried 587 but nothing)
Sender E-Mail Address:
Server admin mail address: my personal email

On the Exchange Server create a new receive Connector (sorry about typing send earlier, Monday morning).
Name it urBackup.
Add the IP of the urBackup server to it.
Now you can do smtp send to your Exchange from the urbackup IP if you provide a username and password of an account with a mailbox.
You must provide Mail server username (empty for none): and Mail server password: in urBackup settings.

If you want so be able to send mail anonymous you must run the following powershell command on the Exchange server.
Get-ReceiveConnector "urBackup" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"
You should leave Mail server username (empty for none): and Mail server password: blank

Sender E-Mail Address: You should be able to type anything here but I know Exchange to want the part to be true on the Exchange server.

Hope it helps, keep us in the loop about your progress.

Thanks for the detail explanation. But i have already done all of this. As i told you, on the same server where Ur Backup is installed, an other application with email notification works ok. Even if i do not add IP server on receive connector for anonymous.
That’s why i’m focusing on UR Backup only.

Ok, then you’ve lost me, since Exchange do not relay messages (with or without username/password) if you don’t have that IP in a receive connector.
Only the Outlook client and webclient is allowed to do that in the default config of Exchange.

Let me know if you think I can be of assistance in the future.

The fakt is that smtp on this server works ok. I have tested it with smtp tester and i can send emails ok. Other applications works ok. Only Ur Backup. Maybe a library is not doing well on Ur Backup. As i know, the configuration on our mail server is done to receive smtp request from an IP range.And the UrB server is on this range. Thats why i’m 100% sure that is not receive connector problem.

So… I am late for the party with this one. What exactly are you trying to do? From what you are saying you are making the attempt to have the server contact you via e-mail; you have tried using Exchange connectors (I know nothing about these, so I will not even try to act like I understand them) and it did nothing - as far as UrBackup is concerned. Everything else works fine with your exchange.

So, just to clarify:

Mail server name:            
Mail server port:                      25
Mail server username (empty for none): 
Mail server password:
Sender E-Mail Address:       
Send mails only with SSL/TLS:          [ ]
Check SSL/TLS certificate:             [ ]
Server admin mail address:   

If all of that looks correct, and you can send emails from then shouldn’t your port be set to what your current mail port is?

And following what you said about:

Have you tried enabling the check-boxes for TLS/SSL?

While I do not know much about e-mail servers, you did never mention changing your TLS/SSL settings - possibly because you don’t use them.

Following up with that:
If you are in fact using 587, then a username/password would be required; however, a TLS/SSL encrypted connection that does not require a username/password would fall under 465, while a normal SMTP connection would be 25.

As i said i tried all combinations. With SSL/TSL, with username and password. I really don’t understand where is the problem. Using smtp tester on the UR Backup server, i can send email with only using my exchange server address and port 25. On the same server i’m using an application for domain password notification and with exchange server address and port 25 works very well. I remember that 1-2 years ago i made an email test with URBACKUP (when i was trying it and testing) and worked. Is there any way to check some logs on UR Backup?

There are two log files in C:\Program Files\UrBackupServer\; app.log and urbackup.log, but I believe the latter is the live log that can be found on your web-interface.

Thanks, but nothing new on this logs. Very strange why is not working.

You could check if this problem still exists with the server 2.0.x beta. If it works there the old version of the library sending the mails in 1.4.x is to blame (cURL).

Unfortunately i tried with beta version and older versions too. I want to say that i tested it in 3 windows server 2008. And all those servers can send mail via smtp. So strange.

If nothing else you could use Wireshark to follow the SMTP conversation (since it is not encrypted). That should give an idea about what fails.

Then you could use cURL via command line to try to reproduce the problem

If i use CURL or other app on the server i can send emails on port 25. The problem is that UrBackup cannot do it. Not the server where it is installed.

@enea009 - Hi is the exchange server authoratititititve for the domain used in the email address, I’ve just set this up using our exdchange server with no problem, configured Receive connector to allow anonymous users, security as secured externally (eg IPSEC), and then added the IP Addy to the list of permitted senders.

Providing the from address domain is in the authorattititititive domain list it sends with absolutely no problem.

(eg if your company email is then the email address you could use as the from address would be something like - if you tried to use, exchange would reject the message, as it isn’t authoratitititititive for it)


I don’t know what the problem is. When i had an issue days before, and the server where Urbackup is installed restarted. The email start to work ok. Then, when i made an update for Urbackup, the problem started again. I want to precise that the server is Windows storage 2012. As i told, if i make a test with a smtp tester on this server, everything works ok. At the moment i cannot restart the server because is a storage one. I 'll try an other restart in a second moment.

The other possible explanation is port being blocked by the other application you mentioned - if that’s holding port 25 open, it won’t be able to connect - does the other application have a service which could be stopped just for testing?

Nothing is blocking port 25. When i mentioned other applications are working. They are not running on this server. I have used them only to test port 25 send mail.

I can also telnet on port 25 my exchange server.