Direct LAN connection is not working any more. (Internet connection is working)

I will try to wrap it up in short.

*) About a year ago I built one UrBackup server in my LAN.
*) I setup multiple clients and these were originally automatically found by the UrBackup server software.
*) Then I made the initial full backups and tested the differential backup features.
*) When everything was working then I packed the whole server hardware in my car and drove to an other location. There I set up my server again and did the work to connect all clients via internet (port forward 55415, domain setup, …)
*) This setup was running fine, as remote backup. But a few days ago I corrupted my server database by restoring an older db file. This was discussed in a different thread. The conclusion was that the only solution will be to bring back the server to my place with the LAN and do again full backups.
*) Yesterday I brought back the server to my place. Now to the problem…

The server is not finding any LAN clients in the network now. I tested to switch the internet domain the public IP of my place. Internet connection is still working.
Also the LAN feature was working at the remote location. So I don’t expect that the server has any firewall misconfiguration. I also disabled all firewalls (on server and clients). I can ping the server from the clients and I can ping the clients form the server with the LAN IPs.

I noticed from the doc that the LAN feature should work over UDP.

55413 FastCGI
55414 HTTP
55415 Internet clients
35623 UDB broadcasts (sending)

35622 UDP broadcasts (receiving)
35623 Commands/Image backups
35621 File backups

I double checked my router configuration. These ports are not used by portmaps or UPNP.
I really have no idea why the LAN feature isn’t working any more although the clients were originally set up in this network.

Would be nice if someone could help.

I just noticed that there has changed one thing on the server. I installed the client on the server. But at the remote location the LAN feature was working with this setup so I would not expect this to be a problem. I also tried to stop the client service and the gui application. still no other clients are detected. But what is interesting is that this localhost client connection to the server is working. Only on the real LAN there seems to be the problem.

Try to manually add a client IP to the server as discovery hint. If this client then works, the UDP broadcast client detection is the problem.

Also, perhaps you have put the client(s) into Internet only mode? Check for args_?.txt in C:\Program files\UrBackup .

Thank you for your answer!

I tried to add the client IP to the server discovery hint.
Now in the “Status” page I see the section “Client discovery hints”
The newly created entry is “” and it is shown as Online= No.

I just double checked. All firewalls are off. I can ping this IP from the server. Client and Server service is running. Even tried to restart both services.

To the args.txt:
I have for example the following file content for one client that isn’t working.



Enabling internet only mode creates extra_args_0.txt (see enable_internet_only.bat)

Thats’s it. I removed this extra file and now it works.
Thank you so much.