Debian squeeze FastCgiExternalServer doesnt work


I 've installed urbackup on debian 7.1 with apache 2.2 yet and backup works fine - thanks :)

But I cannot get the Webinterface at work:

SSL is working, Apaches https ist working, but if I insert “FastCgiExternalServer /var/www/urbackup/x -host” in the fcgi.conf or in apache2.conf theres a Syntaxerror when I restart Apache. The same with FcgidExternalServer.

The pathes is : /var/www with symlink as described.

What is wrong ?


I cant give you the answer for your question but i have a question for you. How do you activate the HTTPS on the Apache for the Urbackup? :roll:

You need to use fastcgi (fastcgi.conf - libapache2-modfastcgi) not fcgi.

Hello urani,

theres no libapache2-modfastcgi in the repository of squeeze. Fcgi follows fastcgi says apache-2.2-doc and so theres no offer for fastcgi.

@svno It was a little bit komplicated , I’ll try later to explain.


I had that problem as well and thought they were fixed. I solved it by compiling the fastcgi package myself. Fcgi is not a replacement of fastcgi, as it does not have the “external server” option that fastcgi does. Apparently Debian has licence issues with the fastcgi module. Maybe we should file a bug against Debian?
You can download it here but getting it running was not trivial for me.
At this point running lighttp or some other server might well be easier.

See here: I think the maintainer is inactive.
With apache >2.3 you could probably use mod_proxy_fcgi . See

Damn! I love Linux since many years, but I hate it for this problems. All privat projects I tried in the last time didn’t work becaus of similiar problems :(
Yes lets file a bugreport.
So what is better/easier- trying to compile the source or upgrade to 2.3 resp. upgrade to sid with apache 2.4 or trying ligttp ?I don’t know.


it works! At last it was simple. The missing package was in the non-free Repository!! I didn’t think at this restriktion because I changed back to debian from Ubuntu - which makes more and more own standards :( . To enable this mod I had to add two symlinks in /etc/apache2/mods-enabled to /etc/mods-available/fastcgi.conf and /etc/mods-available/fastcgi.load. Restart apache and it works. Fine. Thank you for your help and this software :)


Sounds good. I think it is a choose for us to use the ubuntu LTS from the server side. :D

Hello urani,

There will be nice to discover it for apache 2.4. For new apache servers there is not written setting scenario.