Debian: cannot add additional clients

Hi there,

we tried do migrate to FreeNAS and it was a mess. Why do I have to define a jail if only I want UrBackup to make backups of my clients? We migrated to Debian with ZFS instead now and that was really a no-brainer against FreeNAS.

Anyway we have found another problem here now: we cannot add additional clients! If I try with any of the normally working methods (IP, hostname, FQDN), the web interface does sometimes simply nothing, sometimes the field gets empty again as it would be if it was added but the list of additional clients above resides empty.

Bug or feature? ;-)

Hmm, I had some issues with ZFSOnLinux here. Hope it works better for you (Ran out of ram, started locking up the system after a while).

Cannot reproduce with 1.2.4. Which version are you using? Which web browser to access it?

Hi Uroni,

til now no problems, working with dedup and compression… we´ll see.

We run 1.2.4 and tried with IE and Firefox. Problem still persisting, also after reboot.

any idea what we can check or what may be the cause of the problem?

I have no idea what it could be. I have installed it on a fresh Debian 7.1 (wheezy) and it seemed to work. Its about the “extra clients” on the detailed status page, right?
Maybe it’s the name you are putting in. Any special characters or something?

Only hypens ("-"). I don´t think this should be a problem. Our Debian also is 7.1
We tried:

  • hostname
  • fqdn
  • ip address
    Everything does not work - I klick “add” and nothing happens (field does not change, no hourglass, no page reload, nothing). Any suggestion what we can try to solve the problem? Re-Install or re-initialize UrBackup in any way? We need this because we don´t have a single subnet with clients to backup…

Can you install the firefox firebug extension ( ) and send me/post what it shows in the console. Any JavaScript errors or what is sends/receives if you click on that add button.

No errors, no warnings, no infos.


GET https://ba-backup01/x?a=status&ses=8Jeckh92XVPZD...6SdnCQbC&lang=de&details=true&hostname=BA-TPM-JM

200 OK
prototype.js (Zeile 1442)

“allow_extra_clients”: true,
“allow_modify_clients”: true,
“details”: true,
“extra_clients”: [],
“remove_client”: true,
“server_identity”: “#IEnxHKg6xtTX0pjCdA5fP#”,
“status”: [{
“delete_pending”: “”,
“file_ok”: true,
“id”: 1,
“image_ok”: true,
“ip”: “”,
“lastbackup”: “11.10.2013 09:25”,
“lastbackup_image”: “27.09.2013 16:12”,
“lastseen”: “11.10.2013 07:30”,
“name”: “BA-CON-002”,
“online”: true,
“status”: 0
“delete_pending”: “”,
“file_ok”: false,
“id”: 2,
“image_ok”: false,
“ip”: “-”,
“lastbackup”: “”,
“lastbackup_image”: “”,
“lastseen”: “27.09.2013 13:17”,
“name”: “BA-TPM-SO”,
“online”: false,
“status”: 0
“delete_pending”: “”,
“file_ok”: false,
“id”: 20,
“image_ok”: false,
“ip”: “-”,
“lastbackup”: “07.10.2013 11:21”,
“lastbackup_image”: “”,
“lastseen”: “07.10.2013 09:28”,
“name”: “BA-GF-006”,
“online”: false,
“status”: 0

PS: Re-Installed UrBackup and problem persists

Must be an error in the database. if we start with a fresh one after installation it works. Since this is a move from Windows to Debian+ZFSonLinux of course we tried to import the database - seems that this is no good idea.

We export all settings manually (notepad+screenshot) and start from a fresh DB.

Yes, this would have been my best guess now as well. Did you copy the complete database? Because not copying the *-shm. *-journal and *-wal files damages the database in some cases. Using the Windows database on Linux should not be a problem. Best copy a backup UrBackup created.