Confused about map to path / map from path [SOLVED]

Hi, I’m trying to get to grips with the urbackupclientctl linux command line client.
Specifically, I’m curious about the map-to and map-from options.

How is that supposed to work? I assume those parameters are to be used if you want to restore to a different target directory than the original backup.

So according to urbackup my backup path for the file is:
/SnapShots/urbackup_snap_SRV/www/.mysql_history

I would like to restore that file to the directory /test/ on my server.
I’m trying the following command, but I get “Restore failed” error. I also see in the debug logs that urbackup is trying to restore to the original directory.

urbackupclientctl restore-start -b 472 -d SRV/www/.mysql_history -m /SnapShots/urbackup_snap_SRV -t /test/

Ok, seems I got it working.

In this particular case the command is as follows:

urbackupclientctl restore-start -b 472 -d SRV/www/.mysql_history -m /SnapShots/urbackup_snap_SRV/www/ -t /test/

-b is for the backupID
-d is the path to the file or directory you wish to restore
-m this needs to be the full path you wish to remap from.
so in my case, my prebackup scripts creats snapshots in the directory /SnapShots.
I could restore it to the place, but if I want to restore back to my live data, then I need the map function.

-t this is the path you wish to restore to.