Compressed file contains nothing


#1

Hi all,

I have multiple image backups of the Data drive of a server. The files are VHDZ files that are between 196 GB and 210 GB in size. They do NOT appear in the web GUI. The logs show images of the C drive and the SYSVOL drive, but no D drive.

When I try to uncompress each image file using uncompress_image.bat, I select the file and the error that comes back is:

2018-01-06 14:53:14: ERROR: Compressed file contains nothing
2018-01-06 14:53:14: ERROR: Compressed file contains nothing
2018-01-06 14:53:14: ERROR: Error while reading compressed file header

I checked to make sure I have enough space to decompress the file, and I have over 600 GB free on the drive.

I’ve also tried mounting each VHDZ file on an Ubuntu Linux server with UrBackupServer installed on it. I get basically the same error from FUSE.

If these were VHD files, in theory I could directly mount them. Because these are VHDZ files, nothing seems to be able to touch them. I can’t open them with 7-Zip, GZip, Unzip (linux), etc… looking at the header of the file, it appears to be a specialized URBACKUP file format.

So, any other options? I’ve got an entire office of staff looking to me to recover files from the backups, which seemed to be running successfully.

Thanks, in advance!


#2

If it is not shown in the web interface it is quite likely that the backups were not finished.

Otherwise you could attach or send the first few (e.g. 512) bytes of the file and post the exact file size. But as said, it is likely unfinished and the header and footer gets written at the end of the backup process, so that is the likely cause.


#3

Hi uroni,

First, thanks for the reply!

I’ve figured out what’s caused this problem. They’re rotating external USB drives (one per day) in and out of the UrBackup server. So on Day 2, UrBackup goes to verify the contents of Day 1 and does not find the file, so it deletes it from the database. That’s the cause of the missing files. Using SQLite Browser I can manually re-add the entries to the urbackup_server.db file and get them to show back up, but i cannot get them to mount using any method.

They were set to Incremental backups until around 12/21 when they disabled the incrementals and shifted to full backups. Problem is, I can’t find anything on any of the drives past 12/21/2017.

So, assuming the VHDZ files are compressed but OK, is there any way to force (ignore errors) a restore of whatever data is in them? It’s going to be a hard day tomorrow to tell them that we have 300 GB of nothingness in a file if not.

Thanks!


#4

Unless you run “remove unknown” it shouldn’t remote the entries from the database. There should be logs in any case.

They are compressed OK, but not finished. Probably, the footer is missing which maps compressed blocks to uncompressed ones.