Clients v2.5.20 on WinSvr 2008 R2 Not Connecting to Server v2.5.30

I have v2.5.30 server, and it auto updated my clients except for 3 WinSvr 2008 R2 clients which remained v1.4.11. So I downloaded the client v2.5.20 from, and the installation went through without an issue. But none of them will connect to the server. I’ve tried both exe and msi version resulting same error.

Once the client app is installed, it asks to select folders/files to backup, as if it has lost the previous settings. After selecting folders/files to backup, client icon turns red, and cannot connect to the server. Right-click the icon, and the only options are “Access backups”, “About”, and “Status”.

“Access backup” option causes an error “Error getting server URL. Cannot access files.”
“Status” option causes “There was an error. Currently nothing can be backed up.”

Looking at c:/program files/UrBackup/urbackup/data/settings.cfg, I can see the original configuration is intact.

Would appreciate some help.

Same situation, did not found the way to backup 2008 R2 and Windows 7

It could be firewall. I am not sure if there are additional firewall to open since 1.4.11 is before my time. Try to double check if the 3 firewall rules for clients are configured.

It’s not a firewall, at least in my case, I’m trying to update with a fresh install and all modern OSes works but no the Server 2008 R2 and Win 7

I agree with @gosha. Clients on none WinSvr 2008 works fine. These WinSvr 2008 clients have the proper firewall settings, also tried disabling firewall and set DMZ at the router.

On one of the client, I tried uninstall, make sure the urbackup directory is gone, then fresh installed v2.5.20, but still had the same issue. Also fully uninstalled v2.5.20 then tried v2.5.19 with same issue. I am going to try other versions this afternoon.

Edit: One of the WinSvr 2008 client with v2.5.19, since last night’s fresh install, the icon turned white, and full menu is available for some reason. The settings are now accessible, but seems it’s not saving the changes, most likely a permission problem. I do have urbackup user with full control over the directory, so I’ll play with it little more and post the result.

It’s really a big problem because there are a lot of servers with 2008 R2 and older still in use and will be in use very long time. There is no need to update, for example, an SQL server located in DMZ without an access from the internet, so there is a long time 2008 R2 will be in use.

I’ve tried 2.5.19, same symptoms. Please advice any solution without reinstalling the server to the older version?

I’ve tried going back to old versions v2.4.11, v2.4.10, etc. But ran into problems where the UrBackupClientBackend starts up then quits immediately. I’ve messed with folder/file ownerships and privileges, but nothing worked.

I did have Windows Server backup on HDD, did recovery to week ago before I tried upgrading, and it’s working now although it’s still v2.4.11. Looking at the working folder/file ownership and permissions, I don’t see any difference.

I’m just going to leave it. “don’t fix it if it’s not broken”, right? After four days of frustration…

Does someone from urbackup is reading this form? Is it possible to resolve this problem without downgrading the server?

2.5.x doesn’t support Windows 7/2008 R2. You’ll need to stay on 2.4.x for the client.

Obviously someone could contribute changes that make it work on 2008R2, but no one contributed changes when the same happend with Windows XP, so I’m predicting this won’t happen.

Using a prior version of 2.5.x that did not have the installation check yet is of course a bad idea. That check was added because the client did not work on 2008R2.

What the problems was supporting Win 7/Server 2008 R2 at least? Why the client had a problems running on this systems? There are very much of Server 2008 R2 instances is still running and will be running a long time, so this is a really must have compatibility feature