Clients from separate subnet don't connect to server

I set up the server in separate subnet to clients, but none of my clients connect to it.
Server is configured in internet mode, clients are added to server via Add new client/internet client.
Server is pingable, on debian, clients are on Win7/Win10.

Client debug logs shows: 'Internet only mode not enabled. Waiting for local server for 3:00…".
I run “enable_internet_only.bat” script, and after that “extra_args_0.txt” file contains:


I modified the content of extra_args_0.txt file by removing quotation marks:


After service restart, clients connects to server.

Urbackup server version 2.0.31, clients 2.0.29

Thanks for the hint. Will fix the script. I guess it would have work after waiting 3min as well?

Problem was in wrong firewall configuration of my Mikrotik router and broadcasting UDP packets across two subnets. Thats why I’ve tried internet mode.

Anyway, its working fine now.

By the way, thanks for a piece of great software.