Client status window off screen

Under windows sometimes the status window opens to the left of the visible section of my top screen in a dual screen system. I am running a current windows 10 Pro and urbackup client 2.4.10.

Soon after boot selecting “Status” from the tray icon starts a visable status display but after some time the possition at which it opens is off screen to the left. Stopping the tray icon and then starting a fresh instance from the start menu causes the status window opening position to return to the centre of the lower screen.

Dragging the window about before closing does not change the opening position next time.

Yeah, I had the same problem sometimes. I think it is since I updated to Windows 1909. What graphics driver do you have? I’m not sure but I think it might also occur after resume…

This would be a difficult problem to track down… it’s probably a wxWidget problem but I couln’t find any bug reports there.

I am running on a Lenovo W540 which has two display controllers but the fan noise tells me it is using the Intel HD Graphics 4600. Below I have included the display section of the system information captured when there was only a single screen as the computer was undocked.

The problem only occurs with the Status dialog box, the Infos dialog box continues to display but I don’t remember if it’s position changes, I will check next time the fault shows.

In my case it is not subsequent to a resume, I don’t know the triger. It is not related to a backup having taken place. It is not to do with screen savers, screen blanking, sleep or hibernation as I do not use those features.

[Display]

Item			Value	
Name			NVIDIA Quadro K1100M	
PNP Device ID		PCI\VEN_10DE&DEV_0FF6&SUBSYS_221A17AA&REV_A1\4&24E20B30&0&0008	
Adapter Type		Quadro K1100M, NVIDIA compatible	
Adapter Description	NVIDIA Quadro K1100M	
Adapter RAM		(2,147,483,648) bytes	
Installed Drivers	C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_3c9d70a4f9b52aac\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_3c9d70a4f9b52aac\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_3c9d70a4f9b52aac\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_3c9d70a4f9b52aac\nvldumdx.dll	
Driver Version		25.21.14.2591	
INF File		oem145.inf (Section034 section)	
Colour Planes		Not Available	
Colour Table Entries	Not Available	
Resolution		Not Available	
Bits/Pixel		Not Available	
Memory Address		0xB2000000-0xB30FFFFF	
Memory Address		0xA0000000-0xB1FFFFFF	
Memory Address		0xB0000000-0xB1FFFFFF	
IRQ Channel		IRQ 4294967288	
Driver			C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\NVLT.INF_AMD64_3C9D70A4F9B52AAC\NVLDDMKM.SYS (25.21.14.2591, 19.84 MB (20,798,856 bytes), 13/09/2019 10:13)	
	
Name			Intel(R) HD Graphics 4600	
PNP Device ID		PCI\VEN_8086&DEV_0416&SUBSYS_221E17AA&REV_06\3&B1BFB68&0&10	
Adapter Type		Intel(R) HD Graphics Family, Intel Corporation compatible	
Adapter Description	Intel(R) HD Graphics 4600	
Adapter RAM		1.00 GB (1,073,741,824 bytes)	
Installed Drivers	igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igd12umd64.dll	
Driver Version		20.19.15.5058	
INF File		oem144.inf (iHSWM_w10 section)	
Colour Planes		Not Available	
Colour Table Entries	4294967296	
Resolution		1920 x 1080 x 60 hertz	
Bits/Pixel		32	
Memory Address		0xB3400000-0xB37FFFFF	
Memory Address		0x80000000-0x9FFFFFFF	
I/O Port		0x00005000-0x0000503F	
IRQ Channel		IRQ 4294967289	
I/O Port		0x000003B0-0x000003BB	
I/O Port		0x000003C0-0x000003DF	
Memory Address		0xA0000-0xBFFFF	
Driver			C:\WINDOWS\SYSTEM32\DRIVERS\IGDKMD64.SYS (20.19.15.5058, 7.60 MB (7,972,168 bytes), 14/11/2018 00:13)

It just happend after I updated the graphics driver. So perhaps the display has to go away for some time…