Client on local net not found

Just built/installed UrBackup server on Centos6.4 machine which functions as a home network server and installed the client on a win7pro machine. The server has two nics i) internet gateway with iptables firewall ii) intranet without firewall.
The server isn’t finding the client…even after 15min.
? what adapter is urbackup-srv broadcasting on?
? nothing shows in logs…

Hov go ping from the server to the client?

yes, it’s a wide open connection…no firewall

I think you have problem like this

Server says ‘Server rejected’ for a client and does not backup that client

Because of security reasons the UrBackup client only allows the first UrBackup server it sees to back up. For this reasons every server has a random server identity. This identity changes if you uninstall and then install the server or if you use another server. The best option is to prevent this by saving the ‘server_ident.key’ on the server and to restore it if it has changed. If you did not do this your options are:

Delete the 'server_idents.txt', stop the UrBackup client backend service, wait 5min, and start the service again.  
Uninstall the UrBackup client, wait 5min and then install it again. You use your settings if you do this.  
Get the server identity from the server (It is between '#I' and '#' in server_ident.key) and add it to the client's 'server_idents.txt'.

re-installed the client…didn’t seem to help
where is client’s ‘server_idents.txt’ located?
here’s info from the client debug
2013-09-28 19:43:25: WARNING: Upgrading…
2013-09-28 19:43:25: ERROR: Error preparing Query [SELECT tvalue FROM misc WHERE tkey=‘db_version’]: no such table: misc

client’s ‘server_idents.txt’ located in C:\Program Files\UrBackup
try this Get the server identity from the server (It is between ‘#I’ and ‘#’ in server_ident.key) and add it to the client’s ‘server_idents.txt’.

It should be broadcasting on all adapters, btw. Are the client and the server in the same subnetwork?
You can also try adding the client IP to the “extra clients” on the detailed status screen.

server intranet address, client…so yes they’re on the same subnet
installed the windows msi client…no server_idents.txt located in installation folder…is this file created upon installation?

I’ve had a look at the code and there is probably an issue with multiple interfaces (only on Linux). So it is probably broadcasting from the wrong one. I’m working on a fix.

any progress on the multiple nic linux server problem? Is there a way to force use of a particular network interface for connecting to clients

You could try if the version works. There it should use all interfaces on Linux. You should also be able to specify the device via the parameter --broadcast_interfaces, but I haven’t put that into the start_urbackup_server wrapper yet.

I tried to install the server 1.3.0, when I tried to do make, came here this error:

localhost:/home/fabryan/Загрузки/urbackup-server- # make
make all-recursive
make[1]: Вход в каталог /home/fabryan/Загрузки/urbackup-server-' Making all in . make[2]: Вход в каталог /home/fabryan/Загрузки/urbackup-server-’
g++ -DHAVE_CONFIG_H -I. -pthread -DLINUX -g -O2 -MT Query.o -MD -MP -MF .deps/Query.Tpo -c -o Query.o Query.cpp
In file included from Query.cpp:36:0:
DatabaseCursor.h:4:38: fatal error: Interface/DatabaseCursor.h: Нет такого файла или каталога
compilation terminated.
make[2]: *** [Query.o] Ошибка 1
make[2]: Выход из каталога /home/fabryan/Загрузки/urbackup-server-' make[1]: *** [all-recursive] Ошибка 1 make[1]: Выход из каталога /home/fabryan/Загрузки/urbackup-server-’
make: *** [all] Ошибка 2

Sorry, missing file. I fixed that now.

now installed normal