Client never stops indexing


#1

hi all,

I recently upgraded my urbackup server from 1.4.9 on freenas to 2.0.36 as well as upgrading the client on windows 10 to 2.0.34. this is my first time running a backup on my new computer. I set up my paths I want it to backup and manually did the ‘do incremental file backup’ since it wasn’t automatically triggering the backup.

the client shows it as ‘full file backup running. indexing.’ it’s been stuck on that for around 30 minutes now and it hasn’t done anything yet. on the server, if I look at the live log, this is all it shows:

10/14/16 02:54 INFO Starting full file backup…
10/14/16 02:54 DEBUG DESKTOP-91: Connecting for filelist…
10/14/16 02:54 DEBUG DESKTOP-91: Waiting for filelist

any ideas?


#2

What are your client logs; what are your server logs? These can be found in your installation folder.

Were any of your settings changed when you upgraded?

How large is the file system you are trying to perform the full backup on? I am attempting to backup a 2TB server for the first time, and it does take anywhere from a few hours to about two days until it gets the index right – but only for the very first full backup.

You could try running remove_unknown.* or cleanup.* on your server to see if maybe there is an issue there.


#3

I have also know indexing to take more than 24 hours due to the file system size…


#4

hi,

it finally stopped indexing and went to actually backing up files, but it’s running at like 52KBits/s…within the same LAN on my home network! my server is quite capable of running backups at high speeds - I run a xeon 1230 3.3ghz cpu with 16gb of ram and 6 4TB HDDs in raid-z2.

when I backed up my old gaming computer, I recall urbackup backing up around 500-600MB/s.

I’m backing up 34.03 GB of files and it shows an ETA of 2 months 6 days 17 hours 2 minutes. any ideas here? both the server and client settings are set to not throttle the allowed bandwidth. the only setting that changed when I upgraded to a new version of urbackup was to increase the maximal number of incremental file backups.

thanks!


#5

Take a look at the task manager.
I’ve seen this type of performance when the CPU is maxed out.


#6

my cpu is fine…it’s currently at 4% as I write this…meanwhile, urbackup says:

ETA: Approx. 63 days, 18 hours, 13 minutes

something isn’t right here…

@uroni, any ideas here?


#7

Do you have lots of tiny files?
What speeds can you obtain with image backup?


#8

I don’t think anything is too small. that should be irrelevant though,

as mentioned before, I’ve seen it copy 500-600MB/S before on my old gaming computer.


#9

I find lots of very small files can be slow as there’s a lot of stop / start…


#10

right now it’s copying photos that range from 1mb-5mb per photo. still, 63 days is absurd for ~34gb or so.


#11

I agree. I have seen similar posts from others that had encryption turned on with ZFS…
Are you using encryption ?


#12

Do you have it set to background priority?


#13

I’m not using encryption with ZFS, no.


#14

I’m not too sure about this. This is a windows setting, correct?


#15

It should be set on your web-interface, inside of settings, under the advanced tab.

Setting this to background will slow down your connections.


#16

I will check on this tonight when I get home from work. thanks!


#17

background priority is checked in the settings:


#18

Try unchecking it…


#19

ah, that was it! now it’s running at 575Mbit/s as we speak…

thanks, all!


#20

I know this is old, but I have one that never stops indexing, the only way to fix it is to reinstall the client and that only works for a little while.