Client isn't backing up


I recently removed all of my clients from the server, rebooted the server, then my client reconnected back with the server. My client has two paths added to be backed up, and it’s connected to the server, but it hasn’t pushed any backups in almost 24 hours. The client is configured to do backups 1-7/0-24.

any ideas?

Have you tried to manually launch the backup?

@luca91 no, I was seeing if it would automatically start the backup first. I suppose I could try manually running it. why wouldn’t it run automatically though?

so I tried manually running the full incremental backup from within the client. The application icon turned from red (I imagine this could be a problem in and of itself) to yellow with the status of “Waiting on server…”. it sat there for a few minutes and just died off and went back to the red icon; nothing was backed up.

I’m running UrBackup 1.4.8 on both the server & client in a freenas (9.3) jail.

Here’s some screenshots, please let me know if something is off or where I can check logs.

client settings:

server settings:

any ideas @luca91, @uroni, @john3354 ?

Not necessarily. This most usually means that you have not had a successful backup for a while, at least in my experience.

Can you post the logs? You may also want to enable debug logging and attempt again and post the logs. If there is sensitive/private information in there that you are unable to redact for public posting, @uroni is usually pretty good about letting you send the logs to him at his email, but it never hurts to ask first.

@john3354 where are the logs stored? also, how do I turn on debugging?


Here is how to turn on logs: Errorcode: BASE_DIR_LOST (7)
You could also try to uninstall the client and download it again from the web interface, so you could be sure the config is correct.

debug.log (91.2 KB)

@luca91 attached is my log.

@uroni, there are a ton of errors in this log that you might want to take a look over.

1 Like

just wanted to mention that I killed the app after it failed to start the backup after a few minutes.

Hey @uroni, were you able to have a look at the log? I’m still without any backups and it doesn’t get past the “waiting on server…” status.


Can you enable the status column on the server web interface and have look what is shown there?

Also have a look at the server (debug) log, please.

@uroni I’ll have to take a look at the gui when I get home from work to enable the status column on the server interface.

by server debug log, are you wanting the log found in /var/log/urbackup_srv.log?

@uroni, here’s the status column:

I’d prefer to email you the log, if possible.

bumping this. did you have a chance to look at the log I emailed to you, @uroni?

@luca91, @john3354 do either of you know how to turn on debugging on the server?

I’m going to destroy my urbackup jail and reinstall urbackup. I don’t have much of a choice right now…3 weeks and no backups because the client isn’t connecting to the server.