Client for Raspberry Pi Zero W not working


#1

Hello,
I have a running Urbackup 2.2.11 Ubuntu-Server with several connected and working clients (different platform and OS, including Raspberry Pi B).
Sadly, on my Raspberry Pi Zero W’s with Debian Stretch Lite I cannot get the Urbackup Client 2.2.6 to work (older version not tried).

The binary Linux Client from the web page, and even compiling it on the Pi Zero itself results in the same error:
“ERROR: Error creating pthread. Errno: 12” in /var/log/urbackupclient.log while starting the client and the backup-job being stuck in Indexing “Connecting for filelist (async)…”.

How can you get the Urbackup client to work on a Raspberry Pi Zero?

Thanks


#2

I have no solution, but wanted to report that I am seeing this as well.

I have a Raspberry Pi 3 running Raspbian 9.6 (stretch). I’ve tried both the binaries installed via the one-line script, and also building it myself with the --enable-headless option. (I didn’t try building it with the GUI, since I don’t have X installed on the RPi and definitely don’t want to, it’s meant to be totally headless.)

wget https://hndl.urbackup.org/Client/2.2.6/urbackup-client-2.2.6.tar.gz
tar xzf urbackup-client-2.2.6.tar.gz
cd urbackup-client-2.2.6
./configure --enable-headless
make -j4
sudo make install

Everything seemed to build and install correctly. But then I went to start sudo urbackupclientbackend -i -v debug and got this:

2018-12-04 02:34:06: SQLite: recovered 35 frames from WAL file /usr/local/var/urbackup/backup_client.db-wal code: 283
2018-12-04 02:34:06: urbackupserver: Server started up successfully!
2018-12-04 02:34:06: ERROR: Error creating pthread. Errno: 12
2018-12-04 02:34:06: Started UrBackupClient Backend...
2018-12-04 02:34:06: FileSrv: Server started up successfully
2018-12-04 02:34:07: Looking for old Sessions... 0 sessions
2018-12-04 02:34:07: ERROR: Internet mode not enabled. Please set "internet_mode_enabled" to "true".

I’m not exactly sure where the config file lives to try putting it into Internet Mode, but if someone can suggest that, I’ll give it a shot. But I think the problem is in the Error creating pthread line.


#3

Does it work with this one? https://ssl.webpack.de/beta.urbackup.org/tmp/UrBackupUpdateLinux(1).sh


#4

Yes, that version worked flawless on first try on both of my Pi Zero W’s, thanks!
Is it “just” the 2.3.3 beta or is anything changed due to our problem?