Client Exclude Settings Not Downloaded


#1

Hello!

I’m having an issue - I think only with recent releases (it’s definitely worked before) - where the ‘Exclude from backup (with wildcards)’ setting in my Mac client is unpopulated.

I have a large File Backup exclusion list configured on my server - and no client-specific settings enabled to override it.

Any thoughts on where I should start to debug this? I’ve already tried trimming my exclusion list down massively - but still no joy.

Thanks!


#2

Find the settings.cfg file and post it here. It should be somewhere in approx. /Applications/UrBackup Client.app/MacOS/var/urbackup/data/ .


#3

Hi:

Thanks for coming back to me on this. I don’t know if this is expected, but /Applications/UrBackup Client.app/Contents/MacOS/var/backup/data/ is not readable by my usual admin user. On looking at permissions of that area, I see this:

My-Mac:~ root# cd /Applications/UrBackup\ Client.app/Contents/MacOS/var/urbackup
My-Mac:urbackup root# ls -lah
total 728
drwxr-xr-x 14 root wheel 448B 29 Nov 09:32 .
drwxr-xr-x 3 root wheel 96B 17 May 2018 ..
-rwx------ 1 root wheel 98B 29 Nov 09:11 access_keys.properties
-rwx------ 1 root wheel 80K 29 Nov 09:11 backup_client.db
-rwx------ 1 root wheel 32K 29 Nov 09:15 backup_client.db-shm
-rwx------ 1 root wheel 181K 30 Nov 04:19 backup_client.db-wal
drwx------ 4 root wheel 128B 30 Nov 04:17 data
-rwx------ 1 root wheel 0B 29 Nov 09:11 new_server_idents.txt
-rw-r--r-- 1 root wheel 30B 29 Nov 09:11 pw.txt
-rwx------ 1 root wheel 30B 29 Nov 09:11 pw_change.txt
-rwx------ 1 root wheel 1.2K 29 Nov 09:11 server_idents.txt
-rwx------ 1 root wheel 43B 29 Nov 09:11 session_idents.txt
drwxr-xr-x 5 root wheel 160B 29 Nov 09:32 tokens
-rw-r--r-- 1 root wheel 3B 27 Nov 18:08 version.txt

However, here’s the contents of data/settings.cfg:

access_keys=***** - (potentially two keys here, separated by a comma)
backup_window=1-7/0-24
backup_window_full_file=1-7/0-24
backup_window_full_image=1-7/0-24
backup_window_incr_file=1-7/0-24
backup_window_incr_image=1-7/0-24
computername=My-Mac.local
exclude_files=
include_files=
internet_authkey=*****
internet_compress=true
internet_encrypt=true
internet_full_file_backups=false
internet_mode_enabled=true
internet_server=hq.example.com
internet_server_port=55415
internet_speed=-1
local_speed=-1
max_file_full=10
max_file_incr=100
min_file_full=2
min_file_incr=40
startup_backup_delay=0
update_freq_full=2592000
update_freq_incr=43200
client_set_settings=true
client_set_settings_time=1543483859

I’ve redacted the keys for access_keys, internet_authkey and internet_server - please let me know if you need these to debug.


#4

This means you set the settings via client at some point. So it’ll use those unless you set it so that the client cannot change settings on the server.


#5

Hi:

Ah - right. I had set those in the past, but then turned off the individual clients’ settings in Backup Server > Settings > Clients > (client name) > uncheck Separate settings for this client.

I’ve now turned off Backup Server > Settings > Permissions > Allow client-side changing of settings - and that seems to have worked.

Many thanks!


#6

I had the issue with it in the past, i find it particallrly annoying to debug .
Can a hint about it be shown server side, like there is for the * for “Separate settings for this client” ?