Client crash on Windows 2012 server


#1

Hi,

I have installed latest client on Windows 2012 server. Service doesn’t start:

Problem signature:
Name of event issue: APPCRASH
App name: UrBackupClientBackend.exe
App version: 0.0.0.0
App timestamp: 57e95d2e
Name of module with issue: i-ms-win-crt-runtime-l1-1-0.dll
Version of module with issue: 6.2.9200.17313
Timestamp of module with issue: 5507a832
Exeption code: c0000135
Delta exeption: 00000000000e2100
OS version: 6.2.9200.2.0.0.272.7
Language code: 1049
Additional info 1: ac05
Additional info 2: ac0507478d1c5bd693cfc4fe3987e900
Additional info 3: ac05
Additional info 4: ac0507478d1c5bd693cfc4fe3987e900


#2

Sorry you are having issues. To solve the problem the client (debug) log and/or a crash dump would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored, where the crash dump is found and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting

Thanks!


#3

Sure, I tried to run enable_debug_logging.bat, but it doesn’t have effect. Debug log didn’t created.

CMD output:
Disabling debug logging…
Copied files: 1.
"Restarting the UrBackupBackend service…“
Service"UrBackup Client Service for Backups” isn’t runned.

To call additional help run NET HELPMSG 3521.

The service does not respond to the control function.

To call additional help run NET HELPMSG 2186.

To continue, press any key. . .


#4

Crash dump is absent in installation directory.

When I’m trying to run manually UrBackupClientBackend.exe system gives error:

It’s impossible to run program, because api-ms-win-crt-l1-1-0.dll is absent. Try to reinstall software.


#5

Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24215 is installed. Seems api-ms-win-crt-l1-1-0.dll have to be included to Microsoft Visual C++ 2015 Redistributable.

While I’m trying remove Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24215 and try to install latest.


#6

Either your Windows installation is broken or it is not fully updated. See here for a recent user with the same problem and how he fixed it: What is the best OS for urbackup server?


#7

Thank you for link. May be I need to update my system, may be I had to do reboot. I will try.


#8

Solved!

I installed Microsoft Visual C++ 2015 Redistributable (x64) 14.0.23026 from Microsoft site:
https://www.microsoft.com/en-US/download/details.aspx?id=48145

Perhaps, issues grow up from included Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24215 to Urbackup installer. Perhaps, 14.0.24215 required updated system already.