Client connection error

Hi all,
my UrBackup server 2.0.38 is installed on Slackware64 14.2.
I have nearly 30 clients installed in the same network, all running version 2.0.36 in Windows7 or Windows10, with NTFS file system.

Last Friday I’ve installed the clients running the msi installer (with tray icon).
Then I discovered the clients from server console. All clients were found and added to client’s list.
I tried to to an initial full file backup for all clients, but some of them give me a generic message “Starting backup failed” in the server console.

Today some clients are connected to the server, others are not.
If I try to do a backup from command line I receive this error: “Error starting backup. No backup server found.”
Windows Firewall has a rule dedicated to “UrBackup Client Backend”, created by the installer.
All Windows clients has Trend Micro Worry-Free Standard v9, but also the clients that are working well.

Any idea?
Thanks in advance

This normally has something to do with the keys: UrBackup - Frequently asked questions

I am not 100% sure it is the case, since you are saying they have connected to the server…

  • Are you out of drive space to hold images?
  • Inside the web-interface, what are the statuses of the clients that cannot backup?
  • Is your Max Simultaneous Backups set too low?
  • Did you disable file or image backups for your global or client specific settings?

If you need to, you can send a log report in by following this:

Hi ttrammell,
I think the problem is not keys related, because I’ve not changed or reinstalled my UrBackup server.

Now the answers to your questions:

  • I’m not out of space, I’m at 90% of space used
  • In the web interface all clients are marked with status “ok”
  • “Max Simultaneous Backups” is set to 10 and there’s currently no backup activity
  • Yes, I’ve disabled image backup at global level, because I currently have not enough space to do file and image backup.

Could you upgrade to 2.1.x and see if this issue still occurs?

Do you mean 2.1 version on both server and clients?

Preferably both, but server at a minimum - if you are going to upgrade, that is.

I’ve upgraded server to 2.1.17 and some clients to 2.1.13, but nothing changed.

All upgraded clients have status ‘ok’ but are not online and if I force a backup from server console it says me “Starting backup failed”.

Could you try removing the server_idents.txt files from the clients, and restarting their service to see if that helps?

I have deleted the file and then restarted UrBackup backend service. The file has not been re-created and the client is always offline.

In server log I noted “Broadcasting on interface IP”. I’ve not informed you that this server has two NIC in two separate networks ( and All clients are in the network.
But one of the client that has always worked well is the same network as the others.
Can I force UrBackup server to use network?

From what other posts are saying, both NICs should be broadcasting.

Could it be a port problem?

Seems to have solved the issue disabling “Internet mode”. My clients were trying to connect to UrBackup server through the Internet and not in LAN.
Now I’ve created two client groups, one for local clients (connecting through LAN) and another for mobile clients (connecting through Internet).
In the next days I will give you a feedback.

Unfortunately, the problem is not solved.
Today a couple of clients have been able to connect to UrBackup server and do a backup.
But 90% of clients are still unable to connect… I don’t know what to do now.

Did you ever find a solution to this issue? Experiencing with a client which is Server 2012 R2 Data Center which I user as a Hyper-V host for multiple VMs and also mutliple NICs including one used for routing DMZ subnet traffic. Not sure if anything rings a bell or sounds related that you know if a longer term fix, let me know.

I thought I resolved before with the MSI install rather than the EXE but it seems to have returned. Simple want to kick off a fresh new full VM image backup before applying Windows Updates and running into this issue again.

I have to shut down many VMs to power cycle this machine and then check all the VMs have started, etc. once the host server does restart so just wanting to ping some of this by you in case since it’s just a pain for such a simple task.