Client connection but hyperv fails to start backups

Hi All,
I have been trying to get the hyperv client to backup the virtual machines.
client connects and server sees all the vm correctly.
all on windows server 2016.
previously was working fine but one day cleanup went on and on and on and eventually everything stopped working (sorry no idea why probably caused by my blundering)
Uninstalled all clients and server–tried to clean out any files I could see.

Re installed clients and server–both are happy and see each other.
only client that will backup though is the non hyperv client.
no hyperv client will back up and fails instantly.

these lines are from the log:
2020-03-26 15:32:07: Authed+capa for client ‘Secondaryhost’ (encrypted-v2, compressed-v2, token auth) - 1 spare connections
2020-03-26 15:32:07: Authed+capa for client ‘Primaryhost’ (encrypted-v2, compressed-v2, token auth) - 1 spare connections
2020-03-26 15:32:09: Forcing offline client “Secondaryhost[SE-PRODAD]”
2020-03-26 15:32:10: Forcing offline client “Secondaryhost[SE-PRODAD2NDDC]”
2020-03-26 15:32:10: Forcing offline client “Primaryhost[SE-PRODAD2NDDC]”
2020-03-26 15:32:10: Forcing offline client “Primaryhost[SMI Portal]”
2020-03-26 15:32:10: Forcing offline client “Secondaryhost[SMI Portal]”
2020-03-26 15:32:11: Forcing offline client “Primaryhost[SE-PRODAD]”

I tried removing idents file–client comes back online a wee while later as do vm but cannot start backups of vm’s

thanks for any pointers.

replying to myself:
Update–it would seem to be as such–scenario
2 servers, 2 running vm per server
server1= VM1 and VM2
server2= VM3 and VM4

server 1 replicates VM1 and VM2 to Server2
server2 replicates VM3 and VM4 to server1

hyperv on each server, clients connect to offsite backup server correctly and report ALL vm from each server to offsite server.
select any vm to backup and it instantly fails.

disable client on server 2, wait for it to sow as offline on offsite server----hey presto vm backups now work as expected.

Moral of the story is URBackup sees (from what I can guess) BOTH server1 and server2 vm as being the same and so rejects both. I am assuming that URBAckup uses the ggui id of the vm and as they are replicas and same ggui it does not know which one is the real deal and so boots off all the vm on both server.

Would anyone know a way around this? I have tried running all vm on single server but it was not happy, split machine/server setup works but now limited to backing up one server.

Yeah, it uses the Hyper-V uuid to detect renames and then renames… could be it kind of osciallates if both are online. Idk if I understand your setup completely but one work-around would be to use this: Hyper-V VM Snapshot Issue - #8 by uroni

Perfect that will work for me, I will try it in the morning.

On side note would it be possible to have a wild card with the name to exclude any with a certain string in the name.
reason for asking is that when we do backup check we recreate the server and it auto appends an identifier to the end of the original name, it seems that sometimes URBackup detects them and adds them to the server list of vm–not critical just a thought.
thanks again

Update: I have implemented the exclude method suggested above and on the whole it works as anticipated. Except for one vm, the vm had a space in its name, so just in case I removed the space in the name.
all the other excluded vm are not seen but this one vm insists on showing up.
Steps taken
renamed vm on both servers
Stopped all instances of urbackup and restarted server 1st then clients one after the other.

any ideas.
thanks for your help

Hmm, too ideas:

  • The comparison is case sensitive, so maybe the casing differs… It uses the output of powershell Get-VM | fl VMName to get the list of vm names
  • Maybe there are special characters in the VMName? The comparison with the excludes happens before those names get mangled (special characters replaced by _) on the backup server

Thanks for the info, I decided to swap the exclude for include on that server and that worked–I will check the get-vm call to see what it returns and if it is changed by windows.
thanks again, appreciate your help.