Client compiling errors under Ubuntu 12.04

I am trying to build a client for Ubuntu 12.04. The tarball from (3.3M) gives the following error:

main.cpp:287:35: error: request for member ‘ToStdString’ in ‘(((MyApp)this)->MyApp::.wxApp::.wxAppBase::.wxAppConsole::argv + 8u)’, which is of non-class type ‘wxChar* {aka wchar_t*}’
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/home/zsolt/Downloads/urbackup/urbackup-client-1.3.1/client’

The file versioned the same (1.3.1) but from sourceforge ( , 2.9MB) gives:

main.cpp: In member function ‘virtual void MyTimer::Notify()’:
main.cpp:282:43: error: invalid initialization of reference of type ‘wxStandardPaths&’ from expression of type ‘wxStandardPathsBase’

What version of client should I use?


Will I be able to use the software to backup an Ubuntu 12 system? I don’t need the systray and other things related to the Ubuntu Unity, I am perfectly happy with the server http interface: just would like to use urbackup to backup all my machines (one Windows, an Ubuntu 13 and an Ubuntu 12, what I cannot upgrade, because it is not mine). Currently only the first 2 work.



You need to edit a file in client/main.cpp in the official release in order for this to compile with older versions of WxWidget

Open up client/main.cpp, and edit the line

wxStandardPaths& sp=wxStandardPaths::Get();

so its changed to

wxStandardPathsBase& sp=wxStandardPaths::Get();

Then it should compile. I havn’t been able to make it work though (I’m using headless systems though)

Thank you, chluz, you’re brilliant! I succeded to compile the official 1.3.1 client.

I’ll also use it “headlessly”, only from the web interface. The client frontend is known to not work on Ubuntu versions, because of Unity and wxWidgets “incompatibilities”. I think it would be wise to leave the world of taskbar widgets in Linux.


The thanks should go to Uroni, he had it as a fix in his future version, but the 1.3.1 didn’t have it yet.

I would be curious to know if you manage to get it to run, I’ve had issues with seg faults (see this thread :

), Any info on your side that could help me fix it is welcome :)

Wow! Not only it compiled, but I could start the taskbar client as well. So that works in the version 12.04 of Ubuntu desktop. I had a “no backup dirs” issue with the server, but otherwise the backup is working for me. I set up the backup paths in the client.

chluz, sorry I couldn’t reproduce (yet) the seg fault issue you encountered. I could not set up the backup dir in the server, as you mentioned, but got no segmentation fault. I’ll write another post about this. Thanks again!

Thanks for trying ! I setup a VM of 12.04 and it worked flawlessly on that by setting the client up through the web interface. I don’t know why the settings aren’t being pushed for you though. If I have time I will try and investigate more.
Actually if Uroni is ok with it, I’m thinking of trying to setup and maintain a repo for ubuntu LTS + latest. I’ve never done this before, and my contribs to projects have never been so involved, but I really like Urbackup and I think its not getting as much attention at it deserves, so I’d like to change that :)

Actually if Uroni is ok with it, I’m thinking of trying to setup and maintain a repo for ubuntu LTS + latest. [/quote]

Sure. That would be most welcome! Those are the debian files for the server deb-package:

Thanks Uroni, I’ll have a look at these !

chluz, I am sorry, for me the web setup of client did not work on 12.04. But it does work on Ubuntu 13.04, although this is another version of the 1.3.1 client. (There is no taskbar GUI though here, so it’s good that one method works out of the 2 in each case;) and I am not using a headless client.)

I am glad that your problem is solved ;)

Been running the client on Ubuntu 12.04.4 LTS for a while now (started with the 1.2.1 client, then upgraded to 1.3.1). I didnt have any wx errors when compiling and was able to
setup through the web interface. Not sure why I didnt face this problem?

PS as a test just now I am able to export my DISPLAY back to my windows machine running cygwinX and can see the urbackup task bar icon appear remotely through the X server, from here
I can right click and confirugre the client for the machine. I havent triied through the actual Ubuntu machines console though as it doesent have one.

Seems I installed the following packages (although not for urbackup for another purpose) prior to installling urbackup client 1.2.1…

Start-Date: 2014-01-01  17:34:59
Commandline: apt-get install build-essential g++ libwxgtk2.8-dev libcrypto++-dev
Install: libwxbase2.8-0:amd64 (, automatic), libwxgtk2.8-dev:amd64 (, libwxgtk2.8-0:amd64 (, automatic), liborc-0.4-0:amd64 (0.4.16-1ubuntu2, automatic), libgstreamer-plugins-base0.10-0:amd64 (0.10.36-1ubuntu0.1, automatic), wx-common:amd64 (, automatic), libwxbase2.8-dev:amd64 (, automatic), wx2.8-headers:amd64 (, automatic), libgstreamer0.10-0:amd64 (0.10.36-1ubuntu1, automatic)
End-Date: 2014-01-01  17:35:57  

and install log…

Log started: 2014-01-01  17:34:59
Selecting previously unselected package libgstreamer0.10-0.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 240077 files and directories currently installed.)
Unpacking libgstreamer0.10-0 (from .../libgstreamer0.10-0_0.10.36-1ubuntu1_amd64.deb) ...
Selecting previously unselected package liborc-0.4-0.
Unpacking liborc-0.4-0 (from .../liborc-0.4-0_1%3a0.4.16-1ubuntu2_amd64.deb) ...
Selecting previously unselected package libgstreamer-plugins-base0.10-0.
Unpacking libgstreamer-plugins-base0.10-0 (from .../libgstreamer-plugins-base0.10-0_0.10.36-1ubuntu0.1_amd64.deb) ...
Selecting previously unselected package libwxbase2.8-0.
Unpacking libwxbase2.8-0 (from .../libwxbase2.8-0_2.8.12.1-6ubuntu2_amd64.deb) ...
Selecting previously unselected package libwxgtk2.8-0.
Unpacking libwxgtk2.8-0 (from .../libwxgtk2.8-0_2.8.12.1-6ubuntu2_amd64.deb) ...
Selecting previously unselected package wx2.8-headers.
Unpacking wx2.8-headers (from .../wx2.8-headers_2.8.12.1-6ubuntu2_amd64.deb) ...
Selecting previously unselected package libwxbase2.8-dev.
Unpacking libwxbase2.8-dev (from .../libwxbase2.8-dev_2.8.12.1-6ubuntu2_amd64.deb) ...
Selecting previously unselected package wx-common.
Unpacking wx-common (from .../wx-common_2.8.12.1-6ubuntu2_amd64.deb) ...
Selecting previously unselected package libwxgtk2.8-dev.
Unpacking libwxgtk2.8-dev (from .../libwxgtk2.8-dev_2.8.12.1-6ubuntu2_amd64.deb) ...
Processing triggers for man-db ...
Setting up libgstreamer0.10-0 (0.10.36-1ubuntu1) ...
Setting up liborc-0.4-0 (1:0.4.16-1ubuntu2) ...
Setting up libgstreamer-plugins-base0.10-0 (0.10.36-1ubuntu0.1) ...
Setting up libwxbase2.8-0 ( ...
Setting up libwxgtk2.8-0 ( ...
Setting up wx2.8-headers ( ...
Setting up libwxbase2.8-dev ( ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-release-2.8 to provide /usr/bin/wx-config (wx-config) in auto mode.
Setting up wx-common ( ...
Setting up libwxgtk2.8-dev ( ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-release-2.8 to provide /usr/bin/wx-config (wx-config) in auto mode.
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Log ended: 2014-01-01  17:35:57  

Thanks for writing this. What I see is that you have a 64 bit os, while mine is a 32 bit one. I have installed the same packages, following the official instructions from . So I have wxWidgets, for example, but maybe the 32/64 bit makes a difference.