Client Acces/Restore backup from system tray icon and context meny (2.0.4)

When I choose Access/Restore backup from the right click meny of the icon in the system tray.
It opens the url to my server but not on port 55414 or 55415 but port 80.
This works fine for my external tests (reverse proxy fixes the problem) but internally on my LAN not so much since I don’t want to have to go thru the revese proxy in the DMZ and points my url directlly to the urbackup server.

Is this by design och should it open on the normal webinterface port?

Since I was not allowed to post any more in 23 hours (I’ve only made 3 posts?) I’ll include my other findings in this post.

When I right click a file that is in backup folder and choose Access Backup I first get the same URL problem as stated above I also get an error that says (in red) “Sorry, something went wrong or you do not have the required rights to access this file or folder.(path_browse_access_denied)”
The button for login takes me to the standard login and then to the status tab, net the file in question.

I know it’s still in Beta, but I have happy thoughts :wink:


Hi Jorgen,
I have noticed a similar issue when I click Access/Restore backups in the 2.0.19 and 2.0.26 OSX client I get a 404 Error.
It seems the port number is missing from the URL. Once the port number has been added everything is fine.

The problem is exactly the same on the Linux client GUI. The only local Windows client I have here says, ‘Error getting server URL’ when I select Access/Restore from the client (2.0.28) I’ll check other Windows clients later in the week and report back.

I hope this helps with the debugging.


1 Like

The only thing I had to do was add the full URL to the field Server URL under Settings/Server
Can’t speak for your versions of the client but I’m running 2.0.29 server and 2.0.28 client and just tested it on both my Win 8 and 10 machines as well on my win 2012 R2 servers where I have the client installed and it worked as expected.
No linux, sorry :wink:

I tried that and it takes me to port 80 not 55414.
Hopefully Uroni will append the port to the end of the server URL.
It seems to be the same on all the clients I have tried so far.


Just add the port number yourself. He cannot add it, because what about clients that access from outside the local network? They may be accessing on port 80, or 443, or some esoteric port.

Good point…


If you have client on another network segment that can’t access port 55414 you have to use a reverse proxy, port forwarding or other technique that work in your network setup, this is no different from any web page or other traffic behind a routing that don’t forward the right ports?
Nothing special for urbackup.
In the image I provided you specify what urbackup will listen to, URL and port, how you get the traffic there in your network is up to you :slight_smile:

If I check the URL produced by client it shows just the domain name then /#tokens etc. If I then add the port :55414 between the domain and the rest of the URL it works as it should.
I hear what you are saying about adding the port to the domain name. Sure that makes sense. BUT that causes the client to disconnect from the server as the server listening address becomes domain:55414:55415 This I learnt the hard way and I’m still correcting the issue remotely and individually for each offsite machine. Let that be a warning to anyone else with lots of remote systems. If you make a mess of the server address and it’s pushed to each connected client you will have to correct them manually :cry:

So from what I can tell by experimenting the server name AND port number are used by the client / server connection but the when access/restore backups is clicked the domain is used without any port number.

I can’t simply forward port 80 to 55414 as port 80 is already forwarded to a different server. So when I click the access/restore backups on remote clients the page that appears is not urbackup but a page served by the different server.

Is there a work around that I’m just not seeing?
A separate field to specify a port for the web interface would be really helpful here. In fact, since the server already knows which port it’s serving web pages on, just adding the port number into the URL generated by clicking access/restore would do the trick.

Thanks for taking the time to read this,

To my knowlege 55414 is only used for the web interface and 55415 is used for actually doing the backups when it comes to internet clients Admin manual.

The URL you enter under setting/server on the server is what the client tries to open when you choose access/restore backups. It just adds the tokens and what not after it.

I don’t think you can change that URL in the client config settings (the URL in the settings is so that the client finds the server and should not include a port) mayby there is a ini file @uroni ?

I’ve tried to change the port under server/settings/URL, and it should be the full url with http(s):// and everything (, and my clients picked it up when they contacted the server for next backup.

So to get it to work outside your network you need to portforward 55414 and 55415 to the urbackup server and change the server/settings/URL to the correct URL and port.

What you should also strongly consider, if this is a serious installation, is putting a proper web server with SSL in front of UrBackup.

See here:

And then you can put into the Server URL field. And now it should be clear that UrBackup has no knowledge of what you put in front of it and how clients can access the web interface, hence it cannot automatically determine the URL.


And Server name/IP is just the HOST part of the URL, that is the thing that your DNS server resolves to an IP or the IP itself.

If your translations are wrong or if I can change something to make this more clear, please suggest changes…

Thanks for the replies guys.
I understand the terminology, although I’m certainly no expert. The port forwarding is all done and works ok but and here’s the issue. Please, Uroni, correct me if I’m wrong. The URL generated by clicking the access/restore option appears to use the server name in the Internet tab on the server settings followed directly by the tokens, but no port number. Which defaults to port 80.
As the same setting is used to connect the client to the server I can’t add a port, eg, or the client disconnects.
An extra field for web interface port number, defaulting to 55414 and not 80 would do the trick. This could then be added to the access/restore URL…


Please see the previous post about where to enter the URL: Client Acces/Restore backup from system tray icon and context meny (2.0.4)

OK. I can see that I was looking at the URL for the client and not the server settings.
Just to be certain, is this completely separate to the Internet server name/IP: field used by clients to connect to the backup server? The only reason I ask is because it’s taken me two days to remotely reconfigure the existing clients that I managed to disconnect by changing the Internet server name/IP: on Saturday night.

Thanks for your patience,

OK. I finally changed the server address, in the server settings, to the correct URL. It works as expected. Thanks to all and apologies for my stupidity. Glenn

Hello everyone!
Im having a simular error when i try to “Access/Restore” some of my folders. The weird thing is that some of them work JUST FINE no problems at all and others just give me back “Sorry, something went wrong or you do not have the required rights to access this file or folder.(path_browse_access_denied)”
Please help guys!!!


maybe this has been corrected because I did put the port number in the server URL setting and my clients didn’t get disconnected, plus now my clients can use the “access/restore backups” and it works awesome.