Changing servers

Hi. I have a problem with changing servers. I didn’t know where to write it so i’ll describe my situation here.
I’ve got installed latest 1.2.3 server with over 100 clients. And it’s working fine from what i can tell. Lately I’ve installed on second server latest Urbackup server (1.3-1 version). I wanted to move some of the clients to the second server, so i changed on client side server_idents.txt, putting new server key. And here’s what i got:
From approximately 20 clients only 7 connected to new server. Rest of them is rejected. Funny thing is that when i started to look why i saw that some of the clients had in server_idents.txt file, old server key (when I’m sure that I’ve changed it). Replacing it again to new key, did not help (i have server rejected on both servers). Some of the clients have good server key but also are rejecting both servers (re installation of client to 1.3-1 version - not helping). Is there some problem with two Urbackup server instances working simultaneously (two different hardware machines with two different IP’s addresses)?

I’ve had that situation during testing quite a lot of time and have not experienced any problems with it yet. It is not the most user friendly process I guess.
Be carefull that the change does not land in the Windows compatibility layer, though that the clients are rejected by the old server means you changed something.
How did you replace the server_idents.txt?

I’ve “copy overwrite” txt file on remote pc, or edited it manually by replacing server key in txt file. On clients thats rejecting both servers i’ve tried reinstalling it from scratch. But client always firstly connected to the old server. When i’m thinking about it now, maybe it’s somehow connected to my LAN topology. Servers are stored in different physical locations. New one is located further from central node, maybe some packets got lost… .I’ll try to relocate new server to same location as old one maybe this will help. But weird thing is that i can see every single client on both servers, just some of them are rejecting both servers.

Did you remove the #I and # from the server key before writing it to server_idents.txt ?

Of course i did.

Ok, I’ve added a feature to 1.3 now (not uploaded yet - needs some testing) where one can download a client installer with preconfigured server_idents.txt from the server. That may solve this issue.

Grate, I’m waiting for new release.

It’s in now. You need to copy the newest UrBackupUpdate.exe + .sig to the servers urbackup folder for it to work. It will display the download button on the status page.

I’ve downloaded files: UrBackupUpdate.exe 2013-08-15, UrBackupUpdate.sig 2013-08-15, version.txt 2013-08-07 and UrBackup Server 1.3-1.exe 2013-08-10 from this link: . I’ve installed UrBackup Server 1.3-1.exe. Copied UrBackupUpdate.exe 2013-08-15, UrBackupUpdate.sig 2013-08-15, version.txt 2013-08-07 files to C:\Program Files\UrBackupServer\urbackup directory, restarted UrBackup service but no download button is showing up on status page. I’ve tried to copy those files to C:\Program Files\UrBackupServer directory but no success also.

And I’ve found error in UrBackup Server 1.3-1.exe 2013-08-10 version. When you chose to make “Full file backup” from the bottom menu on the status page (press “Start for selected”) it’s making “Incremental file backup”. upper menu works OK.

I just checked and it is only showing the downloads, if the internet mode is enabled. I’ve change it such that it now shows it even if the internet mode is disabled. Maybe that was the issue?

I’ve also fixed the bug where it started the wrong kind of backup.

Yes. Now i can see the download button, but when I’m choosing client from drop down list and press Download i have this error:
ERROR: Signature verification failed. Am I doing something wrong?

The UrBackupUpdate.sig must be the most recent as well and match the UrBackupUpdate.exe . If you are sure they are both the most recent ones, I probably messed up and forgot to update one.

OK I’m sure that i downloaded both files from “Work in progress” folder. I did it now and still I’m having this error.
I’ve tested now server installations. I’ve installed new server, copied both server_ident.key and server_token.key files from old server. I’ve started new server and only 1/3 of clients connected to the new server. Why is that? Rest of them is showing server rejected. Only difference from what i see is that old server is installed on Windows Server 2008 and the new one is on Windows Server 2012. New one is a virtual machine but in the same network. I’ve installed UrBackup on physical machine also (with windows Server 2012) but result was the same. Is there anything else i can check?

Hmm all of them should connect to the new server. You should see more details in the debug-level client and server logs. There isn’t much that can go wrong. The server says: Hey I’m ******, please accept me. The client looks in server_idents.txt if ****** is there and says ok, if yes, otherwise it rejects the server.

I just checked and the signature file seems to match UrBackupUpdate.exe in the WIP folder. Be sure to replace the files in the urbackup/ folder, otherwise I don’t know either what can be wrong. Is this on the Windows Server 2012?

Yes. It’s on the 2012 server. Maybe i don’t know where to put this .sig and .exe files? I’ve copied those files to UrBackup install dir and to “install dir\urbackup”, and i’m sure those are 2 latest files from WIP folder (directly saved to folders from web viewer).
Please help me diagnose what’s the problem with clients not connecting. I have waited 24 hrs to be sure that clients are restarting but after that it’s the same. Some clients are just rejecting server for unknown to me reason. How i can debug this problem?

Hi. Sorry for the earlier posts with changing servers problem. Case solved. It was a problem with firewall application and server configuration. Thnx for your help.

P.S. The problem with downloading configured client from server still remains.

Okay, sorry. Expected one file in the wrong location. I have updated the server and it should work now.

Hi. Now download button works OK.
I have another question-request. Will there be option to force-push this install to client from server control panel? From what i see auto update clients does not work for now (at least in my environment). The latest UrBackupUpdate.exe, UrBackupUpdate.sig and version.txt files (from WIP) are placed in “urbackup install dir/urbackup” folder, and from what i remember “Autoupdate clients:” option should disabled and “Perform autoupdates silently:” option enabled.

I will have to increase the number in version.txt and in the installer. Then it’ll push it to the clients automatically.