CBT stop working

CBT stop working on disk. Can somebody help me. I have version 2.4.12-cbt. I have tried:
urbctctl.exe uninstall r:
urbctctl.exe install r: n-c

Nothing help.

C:\Program Files\UrBackup>urbctctl.exe status r:
Getting status of r: failed. Error code: 317
Change block tracking disabled
Last driver log messages:
Untracked write offset 3132350464 size 4096
Untracked write offset 3081101312 size 4096
Untracked write offset 3194839040 size 4096
Change tracking disabled in IOCTL_URBCT_STATUS
Change tracking disabled in IOCTL_URBCT_RESET_START
Change tracking disabled IOCTL_URBCT_MARK_ALL

Log on client after backup
Starting unscheduled incremental file backup…
Preparing change block tracking reset for volume r: failed: Systém cannot find text message number 0x%1 in file messages for %2. (code: 317)
Scanning for changed hard links on volume of “R:”…
Indexing of “R” done. 25436 filesystem lookups 0 db lookups and 0 db updates
CML[PROF]: Loading file list…
CML[PROF]: Calculating file tree differences…
CML[PROF]: Calculating tree difference size…
CML[PROF]: Linking unchanged and loading new files…
Waiting for file transfers…
Waiting for file hashing and copying threads…
Waiting for metadata download stream to finish
Writing new file list…
All metadata was present
Transferred 333.412 MB - Average speed: 62.5222 MBit/s
Time taken for backing up client CML[PROF]: 3m 20s
Backup completed with issues


Sorry, I have looked into this a bit and I can’t narrow down why it stops working. Ususally the “untracked write” errors occur because the partition size has changed. But then it should work at least if you remove + add it again…

Can you think of seomthing that changed when or before it stopped working?

Yes changed size of partition. I have tried uninstall client reboot delete c:\programfiles\urbackup\ install client reboot.
Nothing change, still is not works.

How much did the volume change? How did you change the size? The write fails at offset 3132350464 . Is that within the new volume size?

Further places to uninstall is deleting the file C:\System Volume Information\urbct.dat. But you need to be sure the driver is not running anymore (sc query urbackupcbt)!
Also perhaps take a look at the registry at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\STORAGE\Volume with UpperFilters urbackupcbt and the Device Parameters of the same.

I installed new disk (ISCSI) then copied (data from old disk to new) and then change drive leter.

I cannot stop urbackupcbt drivers.

C:\Windows\system32>sc query urbackupcbt

SERVICE_NAME: urbackupcbt
WIN32_EXIT_CODE : 0 (0x0)

C:\Windows\system32>sc stop urbackupcbt
[SC] ControlService FAILED 1052:

After uninstalling urbackupclient, driver urbackupcbt still running too.

I haven’t tested it with iSCSI… that is probably why it is not working.

It’d need a reboot.

It worked before changing volume.
Another ISCSI (I,G) drive works fine

Getting status of R: failed. Error code: 317
Change block tracking disabled
Volumes with active change block tracking and no crash persistence (v2.19):
I:, G:,

How to uninstall and install everything as if I was installing for the first time?

I have rebooted and driver still running. Urbackupclient is uninstalled.

What is supposed to be same?