Can't view backed-up files in Backups tab of web interface & new backups not starting

UrBackup Server: 2.4.15
Server OS: Ubuntu 20.04.4 arm64, kernel 4.9.312
Backup path file system: btrfs
Server OS file system: ext4

UrBackup Client: 2.4.11
Client OS: Windows 10
Client file system: ntfs
3 clients all as above

All backups over local (home) network, no Internet backups.

I installed UrBackup Server and Client a few days ago, everything worked fine for about two days (full file and image backups, multiple incremental file backups). Later, I noticed backups were no longer being made, even though they should have been according to the automatic backup schedule. Clients show red UrBackup icon in Windows system tray. Trying to manually start a new backup from the server web interface yields a “Starting Backup Failed” message. Also, a problem that suggests to me something is going wrong on the server side:

When I click the Backups tab in the web interface, I see a File Backups table listing backup times, size, etc., but, when I click on a backup to view the individual files that were backed-up, the web interface fails to respond. The blue spinner in the top right spins as if loading, but never stops spinning. The thin blue line at the top progresses to the right about 99% of the way, but never all the way. I’ve left it like this for hours, but the list of files is never displayed. During the first two days after installation, when everything was working fine, I was able to click on a backup in the web interface and almost instantly see the files that were backed up. This problem occurs regardless of which backup I select – file or image, full or incremental.

When I first saw the client problem, I checked Windows firewall settings and everything seems okay (UrBackup is allowed), nothing changed. Then, when I tried to view backed-up files in the web interface, but could not, I began to suspect a problem server-side.

Note: Some time after the last successful backup and before I noticed a problem, the server was turned off and on.

Server log: urbackup.log (36.0 KB) (includes period of time where I unsuccessfully try to view backed-up files through the Backups tab of the web interface)

Client log: debug.log (5.3 KB)

Thank you for any assistance.

Check and make sure, partition to which backup was targeted is mounted on the server.
Add screenshot for better understanding of the issue.

Thank you very much for your reply. The backup target is indeed mounted (/mnt/urbackup) and this path is the UrBackup settings:

Filesystem Size Used Avail Use% Mounted on
udev 1.9G 0 1.9G 0% /dev
tmpfs 372M 2.1M 370M 1% /run
/dev/mmcblk1p2 30G 4.1G 26G 14% /
tmpfs 1.9G 0 1.9G 0% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
/dev/mmcblk1p1 128M 22M 107M 17% /media/boot
/dev/sda1 9.1T 4.9T 4.3T 54% /mnt/urbackup
tmpfs 372M 0 372M 0% /run/user/0

Screenshot of the web interface after I click on the file backup at the top. Blue spinner in top right, thin blue line gets to about 99% completion in top right, but stays this way for hours without any further progress. For the first two days after I installed UrBackup, when I clicked I would immediately see the list of files, without any problem.

Thank you for your help.