Can't see previous backups after server reinstall


I have the following problem. Recently I had to reinstall the server on which my urbackup-server instance was running. I was not able to save any of the settings present in /var due to the fact that I could not mount the disk at all. However, I use rsync to mirror the backup directory itself to a second disk on another machine. As such I still have the following dirs on the second disk:
clients, HOSTNAE-CLIENT, urbackup, urbackup_tmp_files.

On the primary machine I have the HOSTNAE-CLIENT dir, with all of the old backups before the server was re-installed. The files can be retrieved via scp ot sftp, so they are not lost.

However, I am not able to see the old backups in the web interface for this host, even though it backups to the same dir (successfully) as it has the same host name.

I have tried to restore the clients, urbackup, urbackup_tmp_files dirs from the rsync mirror disk, but that still did not make the old files visible in the web interface, for the client machine, and the client machine refused to connect to the new server.

My question is, is there a possible way to make the previous backups visible in the web interface? I was using urbackup-server version 2.4.13 both before and after the server crash. The server itself is using a Raspberry Pi 2 with arch Linux ARM 5.4.68-1-ARCH.

I am sorry that I can’t provide any log files, but I could not recover them from the failed server at all.

By default there is an automatic backup of the database and other important UrBackup Server files. It is a directory with numerous backup_server* and clientlist_b* files (at least under Windows). Copy the contents of this directory to the matching urbackup program directory on your reinstalled server and you should see the previous settings and backups as before.

Hello. As I mentioned in my post, I was not able to retrieve any files from the /var directory. The only files and directories that are related to the urbackup-server are from the backup path itself, /mnt/BACKUP. These are the things I assume that are mentioned in this link:

When I tried to copy them and restarted the server, not only do I not see the old backups, but the client machine refuses to connect to the server.

The important part of the linked text is that, unless you removed the checkmark from the server setting, the directory /var/urbackup is copied to the backup path (your /mnt/BACKUP) every day during cleanup. Look in your backup path for the urbackup subdirectory. Are you saying you don’t have that directory along with your other client backups?

Hello. On the mirrored disk I have a folder called urbackup (in it I have these files), that was taken from the backup path. I also have all of the old backups, present on both the backup server and on the mirrored disk. After I reinstalled the server I copied all of the contents of this urbackup folder to the fresh urbackup folder in the backup path. When I did this the old backups were not visible and the client could not connect to the server.

That certainly looks like it, and copying those files to complete a reinstall has worked for me in the past, so I’m trying to think of ways it can fail.

Did you stop the UrBackup Server service before you copied the folder? If not, the server files that were open may have become mixed between old and new data.

If you changed the backup storage path as part of your reinstall, restoring settings this way will also restore the previous path. You will need to change that setting to point to where the backups are mounted now.

Pasted below is how it’s described in the Testing forum for returning to a previous version of UrBackup. Perhaps doing the restore of /var/urbackup before reinstalling will work better.

Downgrade process (server)

Stop the UrBackup server, restore C:\Program Files\UrBackupServer\urbackup or /var/urbackup from a backup before upgrade and then install the previous version over the beta release.

Hello. Here is what I tried.

  1. Stopped urbackup-server service
  2. Copy all files from backed up urbackup folder, except the following files:
  3. Restart the server itself
  4. After server restart ssh to server and verify that the urbacku-server service is running.
  5. Verify permissions and ownership of files in the urbackup directory.

After this I logged in to the web interface and verified that the backup path was correct. It was the same as before the server was reinstalled. I also can see the old backups on the disk but they are still not visible in the web interface. The path to the backup folder is the same as before the reinstall and the client machine host name has not changed.