Can't Load Password File

Hi. I’m new to this so please be gentle with the corrections :slight_smile: I installed urbackup server on Ubuntu 14.04 machine. Also installed client on same machine to get started and because I needed a backup of the Ubuntu machine. Installations went fine as far as I could tell. When I fired up the GUI, there was no GUI display at all. Also go message about couldn’t load password file. I dont’ know what to do or why. Since I can’t get to client thru GUI I don’t know how to set password nor what to set it to (e.g. same as server?). Couldn’t find any guidance on this in docs, so I’d appreciate some advice. Thanks in advance.

The tray icon does not work in connection with Unitiy (this is a wxWidgets problem). And I guess the password thing is a bug. I’ll look into that.

I think you are better of not using the client GUI on Linux :wink: (–enable-headless)

That’s ok. I won’t miss the GUI but how to I enter the path names for the backup on the client? I can find no interface at all to the Client app to which I need to set the backup paths. I must be missing something because the client appears to be running (spitting out the message about password file every few seconds) and the server also appears to be running because it too occassionally advises of the password problem (I think), but I can find no way to provide the cleint with info it needs about what to backup like the function that the Windows client has. What am I missing?

Can you configure the directories on the server?

Despite having read the documentation several times, I still must be missing something obvious or else I’m incredibly dull. The reference you provided does not show how to enter the pathnames to a Linux client. Or I’m missing something. Could you provide a linux example. e.g. On the Ubuntu client hat I want to backup the filesystem starts at root and (analogous to c:\ in Windows… I don’t see how the info you show is input to the server (or client). Is there a config file that should be edited with the info or ? How do I get a text string with path or file info into the client? I also realize that I’m confused about your use of “internet” vs a local network. I will start another thread on that seeking clarification.

P.S. I assume that using internet mode means a reconfiguration of the client which is what I did. But I still get message about Internet mode not being enabled. I assume that’s another input to a config file somewhere?

Thanks for tolerating my missing the obvious…

Here’s an example of my confusion. The log message I have when I tried to do backup of client was “Constructing of filelist of “SpockU” failed: no backup dirs. Please add paths to backup on the client (via tray icon) or configure default paths to backup.” Ok. I knew that I hadn’t specified the paths but the message tells me to do so via try icon (doesn’t work in my case on Ubuntu). So, EXACTLY how do I “configure default paths to backup”? Surely there’s a file somewhere that contains this info that can be edited or created?

Kept trying even though not sure I know where to specify backup path. Got these messages from client backup (same machine on which server is running). Backup of Windows 8.1 machine seems to be proceeding ok so far. Not sure what these messages indicate and don’t understand message about internet mode is not enabled.

hec@SpockU:~$ sudo /usr/local/sbin/start_urbackup_client --loglevel debug --no_daemon
2014-10-08 21:58:50: Loaded -fileserv- plugin
2014-10-08 21:58:50: Loaded -fsimageplugin- plugin
2014-10-08 21:58:50: Loaded -cryptoplugin- plugin
2014-10-08 21:58:50: Created new database connection for urbackup/backup_client.db
2014-10-08 21:58:50: ERROR: urbackupserver: Failed binding SOCKET to Port 35623
2014-10-08 21:58:50: Started UrBackupClient Backend…
2014-10-08 21:58:50: FileSrv: Info: retval 0
2014-10-08 21:58:50: FileSrv: Info: retval 0
2014-10-08 21:58:50: FileSrv: Info: Window size=425984
2014-10-08 21:58:50: ERROR: Binding tcp socket to port 35621 failed
2014-10-08 21:58:50: ERROR: FileServ exit with error code: 99
2014-10-08 21:58:51: Internet only mode not enabled. Waiting for local server for 3:00…
2014-10-08 21:58:51: Looking for old Sessions… 0 sessions
2014-10-08 21:58:51: Created new database connection for urbackup/backup_client.db
2014-10-08 22:01:51: Internet mode is not enabled.

I hope that once the lightbulb in my head goes on this will all seem so straightforward because I really need a backup of this machine.

usually you have to put something like


it did worked fine for me once

but actually i have now the same issue as you have :

Can’t Load Password File

the server can list the client, but cannot start anything on it

That message went away but something else is still wrong because I’ve yet to get a backup of any kind from this Ubuntu client. I think I have it setup to backup / (entire system). Will post messages that come from running start client.

See post ‘Backup fails have no idea why’ for messages.