Can't get internet client connected

I’ve been having a problem with an internet client not backing up.
This is the only internet client I have and I just started to use it as an internet client, used to backup as local but it’s no longer local. It’s actually over a vpn so ports aren’t the issue.
I’m using Qurbackup on a Qnap NAS with server version 2.5.32 and client 2.5.25.

It would connect fine, and the SYSVOL would backup but it would always stop at 4% when it was backing up the C drive. I made the mistake of manually deleting the failed backups, they weren’t showing in the “Backups” tab on the server so I didn’t think it would matter but it did.
I then got the “unable to open hash” error, which searching resulted in doing a full image backup should have fixed it, but it wouldn’t.
So then I removed the client through the server last night.
Today it was completely removed so I tried to add it back again.
Now the client says “connected to internet server” but the server always shows it as not connected.
What can I do now?

Also, when you do the “add client”, it then goes to a page with instructions on how to add it.
How can I get back to that page?
I found a post saying it will be on the “admin” page on the server but I don’t have an “admin” page.

the issue is most likely your upnp settings on the Qnas. I use a Asustor nas and there pretty similar. Turn off upnp for that port and manually forward it from your router.

Thanks for the reply but as I said, it’s going over a VPN so ports aren’t an issue.

If it’s over a VPN then it is still local.
Think local client, not internet client.
The client probably still has the previous server key in its server_idents.txt file.
If there is already a key in a client’s server_idents.txt file the client will never find any other server, local nor remote.
Your clients must be manually set up to connect to a second server.

See the following for instructions.

I thought it would still be considered local but it never would connect. Probably 2 weeks into moving it to the VPN I started looking into it and from what I found, if the server is on a different subnet, it’s considered internet.
You’re saying that is incorrect, are you sure about that?

I just followed the instructions you gave and it still isn’t finding a local (nor an internet since I turned that off) server.

Ok, I got it to connect as local.
Even though I can ping the hostname from the server, I put the IP in as a hint in the “add” page.
It then found the PC and is running a backup now. Have to see if it finishes still. Farthest I got was 18% as an Internet client.
Funny thing is it still shows the PC by hostname so not sure if adding the IP was the answer or if I just needed to wait longer.

Multiple subnets don’t matter.
The client and server know that, if it’s anywhere on 10.* or 169.* or 172.16.* or 192.168, it’s local.
I’m sorry, I always use the “IP as a hint” entry to find new clients, even on a single subnet, so I forgot to mention that.
Be sure to fill in the “Server URL for client file/backup access/browsing:” entry on the server’s “General/Server” setup page.
Enter the IP address of the server.
Something like “HTTP://”.
The server finds new clients via a broadcast method, hence the need to use “IP as a hint” to get the server to broadcast to that foreign, but still local subnet.
If the “Server URL for client file/backup access/browsing:” is filled in, the server will inform the client.
Without that IP address of the server, for example, when a server and client are on the same 192.168.1.* box, the server will find the client on before it finds it on 192.168.1.*.
The client’s status page will say that the client is backing up to
It will work but, with the “Server URL for client file/backup access/browsing:” filled in, the client’s status page will say it’s backing up to for example, instead of
I’ve never done an Internet client setup so, I can’t say much about that.

All for now